Java 7 Update 55 - "Application Blocked by Security Settings"

Blog

Sun, 02/15/2015 - 17:04
May 15th, 2014
User Badges:
  • Blue, 1500 points or more

Hello "neighbors"

 

Please be aware of this bug with Java  7 U55.

https://tools.cisco.com/bugsearch/bug/CSCuo78883

 

Symptom:
Administrators for Cisco UCS Manager or users of the Cisco UCS KVM application may encounter an error while opening KVM or Cisco UCSM. A pop-up window with the following dialog may be encountered :

'Application Blocked by Security Settings'

'Your security settings have blocked an application signed with an expired or not-yet-valid
certificate from running'

Conditions:
Cisco UCS Manager or KVM users/admins who are using latest JRE update (1.7 update 55) are likely to see this issue.

Workaround:
Users that have not updated their Java version to 1.7 update 55 should consider delaying the update until a fix in the Cisco UCS Manager becomes available.
If the upgrade was already done, then lowering the Java security settings is another option.

 

 

 

-Kenny

Loading.
Keny Perez Wed, 06/04/2014 - 11:54
User Badges:
  • Blue, 1500 points or more

Great, thanks for the feedback.... I tried it too and worked nicely

-Kenny

andatri Sun, 02/01/2015 - 00:38
User Badges:
  • Cisco Employee,

It's impractical to add thousands of CIMC/UCSM interfaces to the exception list.  Are wildcards possible?


 

cnd000001 Sun, 02/15/2015 - 17:04
User Badges:

Actually - you may also need to export the certificate (save it as a .cer file) and then also add this certificate in java using the "import" option (it accepts .cer fine).  If the certificate is expired, the exception-list alone will not help still.

Actions

This Blog

Related Content