CSM upgrade 4.x - Answers to commonly asked questions.

Blog

Nov 15, 2014 10:10 PM
Sep 24th, 2010

Hello everyone !


Here in TAC, we have seen a lot of customers with questions regarding upgrade of Cisco Security Manager software to version  4.x


I will address some commonly asked questions.



1. What is the latest version of CSM I can upgrade to ?


A: As of 9/24/2010, the latest version available is 4.0.1.



2. Is upgrade to CSM 4.0 from CSM 3.x free ? (like all previous updates to CSM 3.0 release?)


A: NO.

When one upgrades from CSM 3.x to CSM 4.x, this upgrade is not free and new license key had to be procured.

Please contact your Cisco partner/Reseller or account team for purchasing information.


The license key for all CSM 3.x releases is the same.

The license key for CSM 4.x is not the same as CSM 3.x


With a valid license key for a CSM 3.x software,  the newest software you can upgrade to is  3.3.1 SP2

 



3. Can I install CSM on top of my current CSM version ? How do I upgrade CSM ?


The CSM installation can be done in two ways:


Inline upgrade:

In this method you install the new version of CSM on top of the existing CSM version.


Backing up and restoring of data method:

In this method, you back up the database and then uninstall the current CSM version.

Then you install the new version of CSM you wish to upgrade to and proceed with restoring the database.


* The backup/restore of database can happen only between compatible versions. 

E.g : For upgrade to 4.0 via this method, CSM needs to be running atleast 3.2.2.

For all versions 3.2.2 and above, you can backup the database and then restore it back,

after upgrade to 4.0. For all versions below 3.2.2 one cannot.




4. What is my upgrade path ?


A: It depends on whether you wish you retain configuration from the old the CSM version.

If no, then simply uninstall the current version and install the latest one.

If you do wish to retain the configuration, then one needs to follow an upgrade path.

The upgrade path depends on the current software you are running.


Say you want to upgrade to the latest version 4.0.1

The minimum CSM version required before one can make a uprade from 3.x to 4.x is 3.2.2.

The minimum CSM version required before one can even upgrade to 3.2.2 is 3.1.


From CSM 3.0:

First upgrade to version 3.1, then install 3.2.2 (or newer), then install 4.0 and then finally 4.0.1.

3.0  >  3.1 >  3.2.2 >  4.0 >  4.0.1


From CSM 3.1:

First upgrade to version 3.2.2 (or newer), then install 4.0 and then finally 4.0.1.

3.1.x  >  3.2.2  >  4.0 >  4.0.1


From version 3.2:

First upgrade to version 3.2.2, then install 4.0 and then finally 4.0.1.

3.2  >  3.2.2 >  4.0  >  4.0.1


From version 3.3:

First upgrade to version 4.0 and then install version 4.0.1

3.3  >  4.0  >  4.0.1



5. Links for reference ?

Software download CSM:

http://tools.cisco.com/squish/659E11


Installation guides for all releases:

http://tools.cisco.com/squish/D0a1a




Questions/Comments are always welcome !


-------------------------

Sid Chandrachud


Overall Rating: 0 (0 ratings)
l.stafford Thu, 11/17/2011 - 16:55

Hi Sid - great post.

How do I go from 3.1 to 4.2 assuming I am also going to a new physical server but want to keep my current data / configuration intact.

would it be;

3.1 > 3.2.2 > export database > install 4.2 > restore database?

and what do I lose during the database restore, will i need to re-configure anything?

Thanks

WEERAKOO69BA Wed, 01/15/2014 - 03:35

If my version is 4.0 and need to upgrade 4.4 is this possible??

PAUL TRIVINO Sat, 11/15/2014 - 22:10

It would be really handy if this blog (entry) were kept up to date.  I am at 4.4.0 SP2 and I want to go to 4.7.  The information is NOT in the Release Notes where it should be, but in the Install Guide, and it is still not easy to find.

Actions

Login or Register to take actions

This Blog

Posted September 24, 2010 at 10:50 AM
Stats:
Comments:3 Overall Rating:0
Views:3226   
Shares:0

Related Content