Cant Enable SSH

Unanswered Question
Jan 30th, 2007

I have tried to set up ssh on a cisco 850 router. I've used the correct commands and created the keys,etc.

When i run a show ip ssh, it says its disabled. Nothing i seem to do works.

any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 01/30/2007 - 19:36

Robert

I do not have much experience with the 850 so I can not speak from experience. But the first question I would ask is what version and what feature set are you running? Many attempts to enable SSH have foundered on issues of version support and especially on feature set support.

HTH

Rick

royalblues Tue, 01/30/2007 - 22:05

To enable SSH you need to do the following

1. A cryptographic IOS

2. Domain name

3. Generate the key

make sure you have everything in place.

I would suggest to reconfigure SSH and check

Post the results

Narayan

Please rate useful posts

rodonohu1 Wed, 01/31/2007 - 01:23

Hi,

This is the IOS:

System returned to ROM by reload at 13:44:16 GMT Fri Jan 26 2007

System restarted at 13:46:02 GMT Fri Jan 26 2007

System image file is "flash:c850-advsecurityk9-mz.124-4.T.bin"

Weird thing is that SSH was running on this. I then placed a new config on it and ever since it hasn't worked.

Richard Burts Wed, 01/31/2007 - 04:01

Robert

The information that SSH used to work is helpful as is the information that you made config changes and then it stopped working. My guess is that your config changes changed the router name or the domain name, which results in the RSA keys no longer being valid. My suggestion is to generate the keys again and see if SSH works.

HTH

Rick

Actions

This Discussion