vijayasankar Tue, 01/30/2007 - 20:46

Hi,

Kindly provide the exact configurations in your routers (show run output) along with the outputs of "show ip ospf neighbor" and "show ip route".

-VJ

jackyoung Tue, 01/30/2007 - 22:16

Do you mean you cannot find the 'loopback interface' routes at the routers ? If it appears, it may be the host route generated by the PPP, please check the description in the link at bottom.

Or please provide the config.

Hope this helps.

sachinraja Tue, 01/30/2007 - 22:39

Hello,

The first thing you have to check is the Topology database on your router.. this is the first step for any ospf troubleshooting.. can you give a "show ip ospf database" and see if the entry is there ? Only if it in the database, the router will compute the path in the routing table !!!! As VJ told, can you also give us more details ?? Are there any prefix list or route-maps filtering any routes ???

Raj

mheusinger Wed, 01/31/2007 - 04:45

Hi,

there seems to be a bit missing in the example config given following your link.

Router1

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface Serial0

ip address 1.1.1.2 255.255.255.0

!

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

network 3.3.3.3 0.0.0.0 area 0

Router2

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Serial0

ip address 1.1.1.1 255.255.255.0

clockrate 2000000

!

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

network 2.2.2.2 0.0.0.0 area 0

The two additional network statements will include the loopback networks into OSPF and announce them to the neighboring router.

Just following the original config will not give you ospf routes, because OSPF will only announce 1.1.1.0/24 and this network is already in the routing table with better administrative distance, namely being directly connected.

Alternatively you can also configure

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

redistribute connected subnets

To include the loopback networks in OSPF updates.

Hope this helps! Please use the rating system.

Regards, Martin

Actions

This Discussion