Sup720 loading incorrect IOS

Unanswered Question
Jan 30th, 2007

Hi,

Am having a weird problem with a SUP720. I wanted to load a new IOS onto it and it keeps loading the current IOS.

My boot line is:

boot system flash disk0:s72033-adventerprisek9_wan-mz.122-18.SXF7.bin

BOOT variable = disk0:s72033-adventerprisek9_wan-mz.122-18.SXF7.bin,1

Configuration register is 0x2102

The version that the router tried to load is s72033-jk9o3sv-mz.122-18.SXD7.bin

and in my Disk0 I have the following:

1 -rw- 48411760 Jan 5 2006 14:52:32 +11:00 s72033-jk9o3sv-mz.122-18.SXD7.bin

5 -rw- 82524740 Jan 5 2007 11:53:16 +11:00 s72033-adventerprisek9_wan-mz.122-18.SXF7.bin

Has anyone else come across this? Are there any fixes (I have done this on 5 other SUP720's with no problem)

Thanks,

Michael

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Tue, 01/30/2007 - 22:25

Hi

Can you check whether you have one more boot system command configured already which takes more precedence than the recently configured one.

Also have you checked the console while the sup is booting ?

The number followed by the ios file usually denotes number of times the box tried to laod the new ios and given up loading it..

Monitoring the console msgs will also help u too find out the cause for the same..

regds

MIsatchenko Tue, 01/30/2007 - 23:52

Hi Spremkumar,

The only line I have in the config is the one which I supplied above...

I havent been able to check the console because it is currently in production. I will have an outage in the comming days though.

Rgds,

Michael

glen.grant Wed, 01/31/2007 - 00:49

Pretty sure boot statement is incorrect , it should be "boot system flash sup-disk0:

Jon Marshall Wed, 01/31/2007 - 01:17

Hi

The boot statement should work fine. We have the following on one of our 6509's

boot system flash disk0:s72033-entservicesk9_wan-mz.122-18.SXE2.bin

boot system flash sup-bootflash:s72033-jk9s-mz.122-17d.SXB3.bin

I agree that the only way to really troubleshoot this is to do it from console.

Jon

glen.grant Wed, 01/31/2007 - 02:35

?You can boot MSFC3 images from bootflash, sup-disk0, sup-disk1, or sup-bootflash.

Feature Sets

? Features Set Guidelines and Restriction

?The MSFC3 does not require a bootloader image.

?The MSFC2A does not require a bootloader image.

?The MSFC2 does not require a bootloader image.

?You can boot MSFC3 images from bootflash, sup-disk0, sup-disk1, or sup-bootflash.

?You can boot MSFC2A images from bootflash, sup-disk0, or sup-bootdisk.

?You can boot MSFC2 images from bootflash, sup-disk0 or sup-bootflash.

Actions

This Discussion