DHCP server on Cisco 2600 ios 12.0(7)T release same address

Unanswered Question
Jan 31st, 2007

I have configured a 2600 as dhcp-server with this configuration:

!

username AccountRemote password PasswordRemote

!

ip dhcp excluded-address 10.8.0.1 10.8.0.200

!

ip dhcp pool RasPool

network 10.8.0.0 255.255.255.0

default-router 10.8.0.127

!

ip dhcp-server 10.8.0.127

!

interface Ethernet0/0

ip address 10.8.0.127 255.255.255.0

ip nat inside

!

interface BRI0/0

no ip address

dialer pool-member 1

isdn switch-type basic-net3

!

interface Dialer1

ip unnumbered Ethernet0/0

ip nat inside

encapsulation ppp

dialer remote-name AccountRemote

dialer pool 1

dialer-group 1

peer default ip address dhcp

ppp authentication chap

!

Well. When the router receive an IDSN callin, release an address (i.e. 10.8.0.201). If, when the first callin is ON, the router receive a second ISDN callin it release the SAME address 10.8.0.201 of the first connection.

So it doesn't work.

There is a configuration problem?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mheusinger Wed, 01/31/2007 - 03:39

Hi,

you should setup a separate user for each dialin location and modify the dialer interface to remove the remote name.

Currently the router can not tell that ANOTHER router dials to the second B-Channel.

If the SAME router dials to the BRI you should use multilink PPP and channel bundeling.

Regards, Martin

r.mattoni Wed, 01/31/2007 - 03:52

Dear Martin,

the problem is that the users are not routers but PC with isdn-modem and I cannot be sure that nobody uses differents PC with the SAME username. It its happens, the second connection does'nt work but ALSO the first go in bad run (same remote address at 2 differents end-point). Why the IOS doesn't recognize that the address is used in the previous connection?

Regards, Roberto

Actions

This Discussion