Outbound calling from FXS

Unanswered Question
Jan 31st, 2007

I have a H.323 Gateway with a fax machine connected to a fxs card. I can receive calls, but cannot call outbound to the PSTN. I can call IP Phones, just nothing to the PSTN. I have tried several different dial-peers. Is there something needed to allow this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chris.warren Wed, 01/31/2007 - 10:24

I have a PRI connected to the PSTN and an analog phone/fax machine connected to the fxs. You are saying that I cannot place calls from the analog phone to the PSTN through the PRI?

chris.warren Wed, 01/31/2007 - 12:17

Here's my dial-peer config. I've been trying some things with 7 and 10 digit dialing as wel as setting preferences. The fxs is in 0/1/0 and the PRI is 0/0/0:23. We are just getting a fast busy at this point.

dial-peer voice 101 pots

preference 3

destination-pattern 1[2-9]..[2-9]......

port 0/0/0:23

forward-digits all

!

dial-peer voice 1 pots

preference 1

destination-pattern 911

port 0/0/0:23

forward-digits all

!

dial-peer voice 2 pots

preference 2

destination-pattern 8911

port 0/0/0:23

forward-digits 3

!

dial-peer voice 102 voip

preference 4

destination-pattern [1-9]...

session target ipv4:172.18.10.12

dtmf-relay h245-alphanumeric

!

dial-peer voice 100 pots

incoming called-number .

direct-inward-dial

port 0/0/0:23

forward-digits all

!

dial-peer voice 99 pots

destination-pattern 1599

port 0/1/0

!

dial-peer voice 98 pots

destination-pattern [2-9]......

port 0/0/0:23

forward-digits 11

!

dial-peer voice 97 pots

destination-pattern [2-9].........

port 0/0/0:23

forward-digits all

!

I'm curious what number you're using to test with. If you were to dial 18005532447 from your fax machine, it should match dial-peer 101 and all 11 digits should go out. If you dialed just 1800 from the fax, it should wait for inter-digit timeout and then hit dial-peer 102.

I have one customer using a CLEC that won't process some calls unless we send them CID info. Your problem reminds me of that too.

Run a debug to see that you're hitting the correct dial peers. I'd try debug voice ccapi inout.

You can also debug the ISDN and see if you're sending digits to your CO. debug isdn q931 will show some interaction with the CO. Here's a partial output of that debug:

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98396

Exclusive, Channel 22

Calling Party Number i = 0x0081, '4065551800'

Plan:Unknown, Type:Unknown

Called Party Number i = 0xA1, '5557009'

I'd be curious to see the calling and called party number information.

chris.warren Wed, 01/31/2007 - 12:42

For some reason, it is hitting the wrong dial-peer. I just looked at the call history for a specific test call. It is only accepting the first 4 digits.

chris.warren Wed, 01/31/2007 - 12:53

we use 8. That is how I orignally had it setup with a dial-peer of 8T and then I tried .T to match any single character followed by the interdigit timeout. Same result. Is there something I have to do to accept more than 4 digits? It seems like it will only accept 4 digits when dialing.

I think you're matching dial-peer 102 with the 4 digits. Even dialing 8 plus your number is going to match dial-peer 102 the way it is setup I'm afraid. What is your inside number plan? Can you make dial-peer 102 be [1-79]... or do you have 4 digit numbers inside that start with 8? You may have to set up an outside access code of 8 and an inside access code of another digit to get around this dial plan conflict.

chris.warren Wed, 01/31/2007 - 13:18

will [1-79]... work? We exclude 8 from our dialplan since it is an access code. I was under the impression that [1-79] will match 1 through 79.

mschuh Tue, 02/27/2007 - 08:07

use show dialplan number # command to verify dial-peer matching or use debug voice ccapi inout

Actions

This Discussion