RDP over VPN

Answered Question
Feb 1st, 2007

I've been trying for a couple of weeks to establish remote desktop over a vpn with no success. I am able to establish a connection to the vpn but once connected, I am unable to connect by remote desktop.

Building configuration...

: Saved

:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool ippool 10.1.1.3-10.1.1.254

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn address-pool ippool

vpngroup vpn dns-server 10.1.1.2

vpngroup vpn wins-server 10.1.1.2

vpngroup vpn split-tunnel 1021

vpngroup vpn idle-time 1800

vpngroup vpn password ****

vpngroup vpn idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

I have this problem too.
0 votes
Correct Answer by Daniel Voicu about 9 years 7 months ago

Hi,

It could work if you change the users subnet:

no ip local pool ippool 10.1.1.3-10.1.1.254

ip local pool ippool 10.1.3.3-10.1.3.254

access-list nonat permit ip 10.1.1.0 255.255.255.0 10.1.3.0 255.255.255.0

access-list nonat permit ip 10.1.3.0 255.255.255.0 10.1.1.0 255.255.255.0

nat (inside) 0 access-list nonat

Please rate if this helped.

Regards,

Daniel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Daniel Voicu Sun, 02/04/2007 - 23:16

Hi,

It could work if you change the users subnet:

no ip local pool ippool 10.1.1.3-10.1.1.254

ip local pool ippool 10.1.3.3-10.1.3.254

access-list nonat permit ip 10.1.1.0 255.255.255.0 10.1.3.0 255.255.255.0

access-list nonat permit ip 10.1.3.0 255.255.255.0 10.1.1.0 255.255.255.0

nat (inside) 0 access-list nonat

Please rate if this helped.

Regards,

Daniel

Actions

This Discussion