RDP over VPN

Answered Question
Feb 1st, 2007

I've been trying for a couple of weeks to establish remote desktop over a vpn with no success. I am able to establish a connection to the vpn but once connected, I am unable to connect by remote desktop.

Building configuration...

Building configuration...

: Saved

:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool ippool 10.1.1.3-10.1.1.254

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn address-pool ippool

vpngroup vpn dns-server 10.1.1.2

vpngroup vpn wins-server 10.1.1.2

vpngroup vpn split-tunnel 1021

vpngroup vpn idle-time 1800

vpngroup vpn password ****

vpngroup vpn idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

I have this problem too.
0 votes
Correct Answer by acomiskey about 9 years 7 months ago

Lets start over.

You say you are attempting to remote desktop to 10.1.1.2 but then you say you are trying to connect to 10.1.2.1???? Which is it.

Secondly, I think you are going to have issues using 10.x for your vpn clients. Why don't you change it to a 192.168.1.x to cut out some of the confusion. Change...

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.1.0 255.255.255.0

ip local pool vpnpool 192.168.1.1-192.168.1.254

Then, leave out the split tunnel for now til you get connectivity inside.

So you should have...

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.1.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside X.X.X.X 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60

ip local pool vpnpool 192.168.1.1-192.168.1.254

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

route outside 0.0.0.0 0.0.0.0 X.X.X.X 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 dns-server 10.1.1.2

vpngroup vpn3000 wins-server 10.1.1.2

vpngroup vpn3000 split-tunnel 101

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password *******

vpngroup vpn address-pool vpnpool

vpngroup vpn idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
acomiskey Thu, 02/01/2007 - 10:40

First of all you need...

nat (inside) 0 access-list 101

Then if you want your vpn client subnet to be 10.1.2.0, you need to change your address pool for vpngroup to 10.1.2.0. Right now it is 10.1.1.0. If you currently use that pool for inside dhcp, create a second pool for vpn clients.

peteb41976 Thu, 02/01/2007 - 11:29

I appreciate the help. How is this?

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside X.X.X.X 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

route outside 0.0.0.0 0.0.0.0 X.X.X.X 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn dns-server 10.1.1.2

vpngroup vpn wins-server 10.1.1.2

vpngroup vpn split-tunnel 101

vpngroup vpn idle-time 1800

vpngroup vpn password ********

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

acomiskey Thu, 02/01/2007 - 11:49

Now you don't have an address-pool for the vpngroup at all. How about...

ip local pool vpnpool 10.1.2.1-10.1.2.254

vpngroup vpn address-pool vpnpool

peteb41976 Thu, 02/01/2007 - 11:55

Again, thanks for the assist. Should I have any issues with rdp/3389 once the vpn is established?

acomiskey Thu, 02/01/2007 - 11:57

I don't think so, just make sure that after you connect you get an address on 10.1.2.0 subnet. You may also consider adding...

isakmp nat-traversal

That way the vpn will work if you are coming from behind NAT/PAT device.

peteb41976 Thu, 02/01/2007 - 14:11

I just tried from home and anm receiving this error:

17:09:10.531 02/01/07 Sev=Warning/2 IKE/0xE3000023

No private IP address was assigned by the peer

17:09:10.531 02/01/07 Sev=Warning/2 IKE/0xE300009B

Failed to process ModeCfg Reply (NavigatorTM:175)

Any thoughts?

acomiskey Thu, 02/01/2007 - 16:00

Could you post your current config? Is this a different error than before? I don't think you have applied your address pool correctly, that is probably what the client log is complaining about.

peteb41976 Fri, 02/02/2007 - 05:27

This is the current configuration and also an error message I am receiving when I launch the PDM application.

PDM has encountered a firewall configuration that PDM does not support. Configuration parsing has been stopped. PDM access is now limited to the Home and Monitoring views during the current session. To regain access to the rest of PDM, use the command line interface window to fix the unsupported command statement and then refresh PDM with the modified firewall configuration.

Access control list 101 is applied to interface inside for outbounf nat 0 and VPN client group vpn3000 for split tunneling. PDM does not support multiple uses of a given Access Control List.

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside X.X.X.X 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60

ip local pool vpnpool 10.1.2.1-10.1.2.254

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

route outside 0.0.0.0 0.0.0.0 X.X.X.X 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 dns-server 10.1.1.2

vpngroup vpn3000 wins-server 10.1.1.2

vpngroup vpn3000 split-tunnel 101

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password *******

vpngroup vpn address-pool vpnpool

vpngroup vpn idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

acomiskey Fri, 02/02/2007 - 05:51

Which vpngroup are you using? vpn3000 or vpn? If you are using vpn3000 you do not have the address pool applied to that group, you only applied it to vpngroup "vpn". If you are using vpn3000, remove "vpngroup vpn address-pool vpnpool" and add "vpngroup vpn3000 address-pool vpnpool".

Next, you have to create a separate access-list for your split-tunnel, do not use 101.

peteb41976 Fri, 02/02/2007 - 06:27

Okay - I removed "vpngroup vpn address-pool vpnpool" and added "vpngroup vpn3000 address-pool vpnpool"

For the access list, would this be correct? access-list 102 permit ip 10.1.2.0 255.255.255.255

peteb41976 Fri, 02/02/2007 - 07:02

I established the vpn to the 501 and attempted to run remote desktop to the machine at 10.1.1.2 but was unable to do so. The ip assigned to me was 10.1.2.1, subnet of 255.0.0.0 no gateway, dns server of 10.1.1.2 and wins server of 10.1.1.2. The ip I'm trying to connect to is 10.1.2.1, subnet of 255.255.255.0, gateway of 10.1.1.1, public dns servers. Do I need to change the IP that I want to establish an rdp session to 10.1.2.x with a subnet of 255.0.0.0?

Correct Answer
acomiskey Fri, 02/02/2007 - 07:31

Lets start over.

You say you are attempting to remote desktop to 10.1.1.2 but then you say you are trying to connect to 10.1.2.1???? Which is it.

Secondly, I think you are going to have issues using 10.x for your vpn clients. Why don't you change it to a 192.168.1.x to cut out some of the confusion. Change...

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.1.0 255.255.255.0

ip local pool vpnpool 192.168.1.1-192.168.1.254

Then, leave out the split tunnel for now til you get connectivity inside.

So you should have...

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.1.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside X.X.X.X 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60

ip local pool vpnpool 192.168.1.1-192.168.1.254

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

route outside 0.0.0.0 0.0.0.0 X.X.X.X 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 dns-server 10.1.1.2

vpngroup vpn3000 wins-server 10.1.1.2

vpngroup vpn3000 split-tunnel 101

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password *******

vpngroup vpn address-pool vpnpool

vpngroup vpn idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

peteb41976 Fri, 02/02/2007 - 08:58

Here is what I have.Do I want to change the ip of the machine I am trying to establish rdp to 192.168.2.x 255.255.255.0?

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60

ip local pool vpnpool 192.168.2.125-192.168.2.150

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.2.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 address-pool vpnpool

vpngroup vpn3000 dns-server 10.1.1.2

vpngroup vpn3000 wins-server 10.1.1.2

vpngroup vpn3000 split-tunnel 101

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password XXXXXXX

vpngroup vpn3000 idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

peteb41976 Fri, 02/02/2007 - 09:03

Here is what I have.Do I want to change the ip of the machine I am trying to establish rdp to 192.168.2.x 255.255.255.0?

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60

ip local pool vpnpool 192.168.2.125-192.168.2.150

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.2.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 address-pool vpnpool

vpngroup vpn3000 dns-server 10.1.1.2

vpngroup vpn3000 wins-server 10.1.1.2

vpngroup vpn3000 split-tunnel 101

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password XXXXXXX

vpngroup vpn3000 idle-time 1800

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

acomiskey Fri, 02/02/2007 - 09:21

You are trying to rdp from vpn client to inside client correct?

Your vpn client will get 192.168.2.x address. Client on inside you are rdp to will still be 10.x.x.x.

peteb41976 Fri, 02/02/2007 - 10:29

When I established the connection I received 192.168.2.125 as my ip. Once connected, I tried to establish a remote connection to 10.1.1.2 with no luck.

The ip I'm trying to connect to is 10.1.1.2 subnet of 255.255.255.0, gateway of 10.1.1.1, public dns servers

I also noticed that I am receiving no default gateway with the vpn connection. Could this be the problem?

I am able to connect to \\10.1.1.2 and access files.

peteb41976 Fri, 02/02/2007 - 10:42

Any idea why I can access \\10.1.1.2 but not establish rdp to the same address?

acomiskey Fri, 02/02/2007 - 10:45

So the vpn works?

Windows firewall maybe? Can you rdp to 10.1.1.2 from the inside?

peteb41976 Fri, 02/02/2007 - 11:01

It is working. Thanks for all of your assistance. I've checked on both the client and the server and both are set to allow rdp

peteb41976 Fri, 02/02/2007 - 11:51

The vpn and access to \\10.1.1.2 are working. RDP to 10.1.1.2 still isn't.

acomiskey Mon, 02/05/2007 - 07:39

So the rdp connection not working has nothing to do with the vpn.

Make sure rdp is enabled on server and that no firwall between you and server is blocking tcp 3389.

peteb41976 Mon, 02/05/2007 - 07:47

I tried with the firewall set to allow rdp and then with no firewall with no luck. Are there any settings on the PIX I would need to enable?

acomiskey Mon, 02/05/2007 - 07:53

If you are on inside coming from 10.1.1.x and attempting to hit 10.1.1.2, the traffic would not be hitting the firwall.

peteb41976 Thu, 02/08/2007 - 16:52

Okay - When I am at work I can launch the vpn client, receive a 192.168.2.x address, and connect to \\10.1.1.2

When I am at home, I can launch the vpn, receive a 192.168.2.x address and I am unable to connect to \\10.1.1.2 I even changed all of my internal router settings at home to match those at work. (both hand out 192.168.1.x addresses) I am completely stumped. If I couldn't connect to the vpn at home I would think there was a setting which needed to be changed. But, everything is the same.

peteb41976 Fri, 02/09/2007 - 06:28

I think it has to do with either a program or protocol on my notebook. I tried connecting from work - with my notebook - and was able to connect to the network but not to \\10.1.1.2. I uninstalled the SQL desktop engine, disabled all of the software firewalls and was able to connect.

peteb41976 Sat, 03/31/2007 - 05:29

Hi again - The issue I seem to be having now is that only one session can connect to the vpn at a time. Also, I can only RDP once; if I rdp, close the session, and try to rdp again, I am unable to do so. Here is my current config.

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password ******

hostname ****

domain-name *****

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol pptp 1723

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 10.1.1.0 255.255.255.0 192.168.2.0 255.255.255.0

pager lines 24

logging on

mtu outside 1500

mtu inside 1500

ip address outside X.X.X.X 255.255.255.0

ip address inside 10.1.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm

ip audit attack action alarm drop

ip local pool 10.1.2.32-10.1.2.62 255.255.255.0

ip local pool ippool 10.1.2.32-10.1.2.60 mask 255.255.255.0

ip local pool vpnpool 192.168.2.125-192.168.2.150 mask 255.255.255.0

pdm location 1.2.3.5 255.255.255.255 inside

pdm location 10.1.1.32 255.255.255.255 inside

pdm location 10.1.1.2 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 101

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 X.X.X.X

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.2.0 255.255.255.0 inside

http 10.1.1.32 255.255.255.255 inside

http 10.1.1.2 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 10.1.1.32 c:\cisco

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 address-pool vpnpool

vpngroup vpn3000 dns-server 10.1.1.2

vpngroup vpn3000 wins-server 10.1.1.2

vpngroup vpn3000 split-tunnel 101

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password ********

telnet 10.1.1.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

management-access inside

console timeout 0

dhcpd auto_config outside

terminal width 80

mlitka Mon, 04/16/2007 - 05:01

From experience, intermittent RDP issues over VPN go hand in hand with MTU problems. You will probably also notice that SMTP is having issues as well. I would recommend lowering your MTU values. I have had this issue multiple times when working with site to site VPNs between routers. Unfortunately, I am not sure of the configuration statements required for a client/server model, like your using here.

Actions

This Discussion