Failed SDM update

Unanswered Question
Feb 1st, 2007

I tried updating SDM to the latest release, but failed doing so:

On the router's SDM Express interface I downloaded the update from cisco.com's website to my notebook (Win XP). Then started the installer.

After first failure, it advised me to follow some steps (active http/https server of the router, add user with level 15, configure ssh/telnet for level 15).

I did so and installation seems to work till the installer stated "Copy files to router". Then installation stopped with an error ("file transfer to router not possible" or similar).

Now when I call my router's WAN-IP, I don't get the SDM Express frontend anylonger, but some kind of "HTML terminal". Anyway, the router still seems to work fine.

So my questions are as following:

1. How can I get back SDM Express without destroying the router's configuration ?

2. When done, how do I properly update the SDM version ?

This is how my configuration looks like (show running-conf)

Building configuration...

Current configuration : 2321 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname adsl-gw

!

boot-start-marker

boot-end-marker

!

logging buffered 10000 debugging

enable secret 5 ####################

!

clock timezone PCTime 1

clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

!

!

ip cef

ip ips po max-events 100

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

no ftp-server write-enable

!

isdn switch-type basic-net3

!

!

username ##### privilege 15 password 7 #######

!

!

no crypto isakmp ccm

!

!

!

interface BRI0

no ip address

shutdown

isdn switch-type basic-net3

!

interface FastEthernet0

description zum DSL modem

no ip address

speed auto

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Vlan1

description LAN

ip address 194.77.100.89 255.255.255.248

!

interface Dialer1

description T-DSL dialer

ip address negotiated

ip access-group 102 in

ip mtu 1492

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp chap refuse

ppp pap sent-username ###### password 7 #######

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

ip http access-class 9

ip http authentication local

ip http secure-server

!

!

!

access-list 9 permit 194.77.100.88 0.0.0.7

access-list 101 permit ip any any

access-list 102 deny udp any 194.77.100.88 0.0.0.7 eq 3283

access-list 102 deny tcp any 194.77.100.88 0.0.0.7 eq 3283

access-list 102 deny udp any 194.77.100.88 0.0.0.7 eq 5900

access-list 102 deny tcp any 194.77.100.88 0.0.0.7 eq 5900

access-list 102 deny tcp any 194.77.100.88 0.0.0.7 eq 22

access-list 102 deny udp any 194.77.100.88 0.0.0.7 eq 22

access-list 102 deny udp any 194.77.100.88 0.0.0.7 eq 23

access-list 102 deny tcp any 194.77.100.88 0.0.0.7 eq telnet

access-list 102 permit ip any any

dialer-list 1 protocol ip list 101

!

!

control-plane

!

!

line con 0

password 7 ###########

login

line aux 0

line vty 0 4

privilege level 15

password 7 ############

login local

transport input telnet

!

end

(User names and passwords have been replaced with #####)

I really look forward your kind assistance :-)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tobiaseichner Fri, 02/02/2007 - 02:06

Have I mistakenly used the wrong forum ? Please direct me to the correct one if this was the case...

Actions

This Discussion