Redistributing Static Routes to EIGRP

Unanswered Question
Feb 2nd, 2007

Hi,

I read here in Cisco website that in order to redistribute routes from one protocol to EIGRP, it should have a default-metric set or a metric set for the routing protocol. If there's no metric set then the route will not be redistributed.

Im wondering why our MSFC2 is redistributing static routes without metric.

Here's the configuration:

--------------------------------------

router eigrp 30

redistribute static route-map redist

redistribute bgp 25612 metric 1536 2000 255 1 1500 (I changed the AS#)

network 10.0.0.0

network 192.168.254.0

no auto-summary

eigrp log-neighbor-changes

ip route 10.199.180.0 255.255.255.0 10.199.56.51

ip route 10.199.238.0 255.255.255.0 10.199.56.51

ip route 10.200.20.178 255.255.255.255 10.199.56.115

ip route 10.200.20.189 255.255.255.255 10.199.56.115

ip route 10.200.20.190 255.255.255.255 10.199.56.115

access-list 5 permit 10.200.20.182

access-list 5 permit 10.200.20.178

access-list 5 permit 10.200.20.190

access-list 5 permit 10.200.20.189

access-list 5 permit 10.199.238.0 0.0.0.255

access-list 5 permit 10.199.180.0 0.0.0.255

route-map redist permit 10

match ip address 5

--------------------------------------

When I checked the routing table of the other routers, it can still see the redistributed routes from the MSFC2 and flagged as an external EIGRP (170).

Im wondering why this redistribution happened.

Please help. I'm confused. =(

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (3 ratings)
Loading.
mike-greene Fri, 02/02/2007 - 05:27

Hi,

Static routes are not considered a routing protocol so in your case the "redistribute static route-map redist" command redistributed them into EIGRP. Your BGP config will not redistribute without the default metric set in EIGRP.....that is considered redistributing between routing protocols.

HTH.

John Patrick Lopez Sat, 02/03/2007 - 00:57

Thanks Mike!

What metric will the MSFC EIGRP use to advertise this redistributed static route?

I'm still confused because of this TAC Case I read.

http://129.41.16.73/kaidara-advisor/iprout/showcase?case=K24151683

Just in case you can't open it:

Resolution:

Ensure that a metric is configured by issuing the redistribute command, as shown in this example:

router EIGRP 7

redistribute static metric 10000 1 255 1 1500

Whenever routes that should otherwise be advertised through EIGRP are not being advertized by EIGRP, it is important to check any outgoing distribute-list commands or filters that may be associated with the redistribute command.

Also, if any distribute-list commands are used or filters are associated with the redistribute command, ensure that these filters and distribute-list commands allow for the network(s) in question to be advertised.

rtanner Sun, 02/04/2007 - 14:13

I agree that metrics are required when redistributing static routes. Can you confirm that the routes are in the EIGRP toplogy table? And that they are _not_ being redistributed from BGP?

John Patrick Lopez Sun, 02/04/2007 - 19:24

Thanks for the reply rtanner.

When I checked the configuration of the MSFC, the only route to 10.199.180.0 is a static route. No other router advertises this subnet because it is just a DMZ. We only redistribute BGP default routes so this is just a public IP. I'm wondering why all our routers here in our organization have routes to that 10.199.180.0 network and it also has a metric and the AD is 170 which means that it is a redistributed route. But the MSFC doesn't have a metric for that static route. The metric was only configured for redistributed BGP route.

I read an article here in Cisco website that says redistributed routes for EIGRP "may require" metrics. I'm wondering why it says "may require" but the article didn't elaborate why.

Thanks.

rtanner Mon, 02/05/2007 - 19:18

If you are still wondering, could you post the output of

show ip eigrp topology 10.199.180.0

? It may give more of a clue ...

or we could just shrug our shoulders and get on with our lives!

John Patrick Lopez Mon, 02/05/2007 - 20:15

Hi rtanner,

Router112#sh ip route 10.199.180.0

Routing entry for 10.199.180.0/24

Known via "eigrp 30", distance 170, metric 28416, type external

Redistributing via eigrp 30

Last update from 10.199.56.2 on FastEthernet0/0, 2d20h ago

Routing Descriptor Blocks:

* 10.199.56.3, from 10.199.56.3, 2d20h ago, via FastEthernet0/0

Route metric is 28416, traffic share count is 1

Total delay is 110 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 4/255, Hops 1

10.199.56.2, from 10.199.56.2, 2d20h ago, via FastEthernet0/0

Route metric is 28416, traffic share count is 1

Total delay is 110 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 4/255, Hops 1

Router112#sh ip eigrp topo 10.199.180.0

% IP-EIGRP (AS 30): Route not in topology table

Router112#

The 10.199.56.2 and 10.199.56.3 are both MSFC. And the MSFC has a static route to the firewall 10.199.56.51.

ip route 10.199.180.0 255.255.255.0 10.199.56.51

I already posted the MSFC config above.

Thank you very much rtanner. =)

rtanner Mon, 02/05/2007 - 20:19

can you run the same commands on the MSFC? I assume Router-112 is downstream ...

John Patrick Lopez Mon, 02/05/2007 - 20:51

MSFC01#sh ip eigrp topo 10.199.180.0

% Route not in topology table

MSFC01#sh ip route 10.199.180.0

Routing entry for 10.199.180.0/24

Known via "static", distance 1, metric 0

Redistributing via eigrp 30, ospf 1

Advertised by eigrp 30 route-map redist

Routing Descriptor Blocks:

* 10.199.56.51

Route metric is 0, traffic share count is 1

MSFC01#

What do you mean by downstream?

rtanner Mon, 02/05/2007 - 21:05

Downstream - meaning away from the point of interest ...

I missed the mask - can you run

sh ip eigrp topo 10.199.180.0/24

on the MSFC?

But that said, I just put EIGRP on a router and redistributed a static route without specifying a metric ... and it appeared in the topology table. Now I am searching CCO for some indication that the behaviour is changed. I am running v12.4.

John Patrick Lopez Mon, 02/05/2007 - 21:15

MSFC01#sh ip eigrp topo 10.199.180.0 255.255.255.0

IP-EIGRP topology entry for 10.199.180.0/24

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2816

Routing Descriptor Blocks:

0.0.0.0, from Rstatic, Send flag is 0x0

Composite metric is (2816/0), Route is External

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 10 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 0

External data:

Originating router is 10.199.252.2 (this system)

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.199.56.3 (Vlan1), from 10.199.56.3, Send flag is 0x0

Composite metric is (3072/2816), Route is External

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 20 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

External data:

Originating router is 10.199.56.3

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

MSFC01#

MSFC02#sh ip eigrp topo 10.199.180.0 255.255.255.0

IP-EIGRP topology entry for 10.199.180.0/24

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2816

Routing Descriptor Blocks:

0.0.0.0, from Rstatic, Send flag is 0x0

Composite metric is (2816/0), Route is External

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 10 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 0

External data:

Originating router is 10.199.56.3 (this system)

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.199.56.2 (Vlan1), from 10.199.56.2, Send flag is 0x0

Composite metric is (3072/2816), Route is External

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 20 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

External data:

Originating router is 10.199.252.2

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

We are using 12.1(26)E1

I really appreciate your help. Because I'm currently studying for my CCIE written that's why I'm asking. =)

rtanner Mon, 02/05/2007 - 21:28

Good luck ! All I can think is that - contrary to documentation - statics don't need the metric configured since they generally point out an interface, and the factors that make up the EIGRP metric are available from that interface e.g

MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec,

reliability 255/255, txload 1/255, rxload 1/255

John Patrick Lopez Mon, 02/05/2007 - 21:37

Actually I tought of that already but of course, I want to hear it from the expert, a CCIE. =)

I'll try to simulate it on other routers if I have time then see if I'll get the same result.

Thank you very much for your time Ross. Really appreciate it. =)

royalblues Tue, 02/06/2007 - 07:07

When Static routes are redistributed without metric, it actually applies a default seed metric to the route.

I am not able to find the exact seed metric Eigrp applies but it is 20 for OSPF.

HTH, rate if it does

Narayan

royalblues Tue, 02/06/2007 - 07:31

Hi

I did a Lab simulation and found that the router redistributing the static route actually assigns a FD of 1 to the route

(shows as Rstatic in topology)

The other routers upstream/downstream add up the normal metric to this (bandwidth+delay)

HTH, rate if it does

Narayan

ruwhite Tue, 02/06/2007 - 16:13

I've not followed the thread, and I don't claim to be an expert, but... :-) I saw this one question and thought I'd at least give it a shot!

I just checked in the lab, and EIGRP will redistribute a static without a metric. I had realized this for statics to connected next hops and to interfaces, but not for those with next hops learned through another protocol (this is the one I wanted to check in the lab). In effect, what EIGRP does is to take the metrics from the interface through which the static points, or through which the next hop for the static is reachable.

HTH.

:-)

Russ

rtanner Tue, 02/06/2007 - 16:24

now all we need is the CCO reference stating that is indeed the case !

In theory, practice and theory operate the same. In practice, they don't.

sundar.palaniappan Tue, 02/06/2007 - 16:48

I remember reading a document on CCO a few days ago that did state static/connected route redistribution into EIGRP doesn't need explicit metric association or default metric configuration. That was the first time I realized that. I can't seem to find the document now.

I don't understand the inconsistency in metric requirement between static/connected routes versus routes learned via other sources during redistribution. Static/connected routes using the interface attributes for metric calculation implies the source network is directly connected to that interface and that's not always the case.

Just my 2 cents.

HTH

Sundar

Actions

This Discussion