ESM Cisco embedded switch/IBM blade server

Answered Question
Feb 2nd, 2007

Hello,

I am having problems with an embedded cisco switch. It came with an IBM blade server. My server admin should be able to configure mutliple vlans on each blade instance. I can assign each blade to a particular vlan, but then the whole blade becomes member of that vlan. He keeps telling me I need to trunk my ports. I turn trunking on and then he can't get to his VM's. He has multiple VM's per blade. I only have 14 ports to work with. Each port on the embedded switch (it's virtual, it only has 4 physical ports) is in vlan200. He wants one vm to be in vlan200 and one in vlan11...etc etc. Does anyone have a good tech reference? Thanks

Attachment: 
I have this problem too.
0 votes
Correct Answer by glen.grant about 9 years 7 months ago

It looks good , I don't think we used portfast on the links , no reason it would need it . Also if you are trunking and using transparent mode just verify you have created your layer 2 vlans , don't see them in the config . Verify how you want vtp setup , transparent or cleint etc ... The rest looks good , myself I would manually prune off any unneeded vlans off your etherchanneled uplinks .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Jon Marshall Fri, 02/02/2007 - 15:09

Hi

Firstly your links from the embedded switch back to your core switches will need to be trunk connections.

Is the server admin running 802.1q trunking on the server, he will need to set this up and you will need to make them trunks. If you assign the blade to just one vlan then all the VM instances on that blade would have to be in that vlan.

HTH

Jon

glen.grant Sat, 02/03/2007 - 13:14

Your server guy is correct you can trunk all 14 of those ports . Normally we just trunk the ports to trunk vlans 1 -1005 then they can put the servers anyway they want . You then setup the uplinks to trunk whatever vlans you need trunked up to the layer 3 routing device whether its a layer 3 switch or a router . When doing your vlans setup the vlans so that the layer 3 switch is the root of the spanning tree . Those 4 ports on the switch are your uplink ports to your layer 3 device . you can trunk and etherchannel one or more of those ports together if you want the extra bandwidth to your routing device.

It's not that bad think of those 14 ports as regular switch ports each one assigned to one server that has a nic card that is capable of trunking as that is what it is really doing and those final 4 ports are your uplinks , you do not have to use all 4 that is up to you how much bandwidth you need to go upstream .

santa_cruz Mon, 02/05/2007 - 11:18

Thank you for your input. I think what you are saying is this: configure all 14 "switchports" to be trunks, and if he needs vlan 11, or vlan200 change the config to say, switchport mode trunk vlans allowed 11,200.

then on the 4 "external" ports, they are all trunks, redundant or ehterchannel. What about interfaces 15 and 16? What do I have to do for them? The 'management' ports, for the management module.

glen.grant Mon, 02/05/2007 - 11:21

I would setup the server ports as trunks allowing all vlans , then you would not have to modify those ports again then just allow the needed vlans across your uplinks .

santa_cruz Mon, 02/05/2007 - 13:24

Hello Glen,

I've setup as you suggested. I've put switchport mode trunk then

switchport trunk allowed vlans 1-1005

i also added spanning tree portfast. Do I need that?

From my perspective, we're good! Although, now the server guy is hosed because he can't get SQL playing nice with his server. BUT, I think my side is done correctly, here is my config...

spanning-tree mode rapid-pvst

spanning-tree loopguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

macro global description cisco-global

!

!

interface Port-channel1

switchport mode trunk

!

interface GigabitEthernet0/1

description blade1

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/2

description blade2

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/3

description blade3

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/4

description blade4

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/5

description blade5

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/6

description blade6

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/7

description blade7

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/8

description blade8

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/9

description blade9

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/10

description blade10

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/11

description blade11

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/12

description blade12

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/13

description blade13

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/14

description blade14

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/15

description mgmt1

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100

!

interface GigabitEthernet0/16

description mgmt2

switchport mode trunk

switchport nonegotiate

spanning-tree cost 100

!

interface GigabitEthernet0/17

description extern1

switchport mode trunk

channel-group 1 mode desirable

!

interface GigabitEthernet0/18

description extern2

switchport mode trunk

channel-group 1 mode desirable

!

interface GigabitEthernet0/19

description extern3

switchport mode trunk

!

interface GigabitEthernet0/20

description extern4

switchport mode trunk

switchport nonegotiate

!

interface Vlan1

ip address 172.22.1.201 255.255.255.0

no ip route-cache

Thank you for your version of explaining this. I had no idea it was that simple! what do u think of spanning tree portfast?

Cat

Correct Answer
glen.grant Mon, 02/05/2007 - 16:02

It looks good , I don't think we used portfast on the links , no reason it would need it . Also if you are trunking and using transparent mode just verify you have created your layer 2 vlans , don't see them in the config . Verify how you want vtp setup , transparent or cleint etc ... The rest looks good , myself I would manually prune off any unneeded vlans off your etherchanneled uplinks .

santa_cruz Tue, 02/06/2007 - 09:33

Hi Glen,

Today the server guy can't seem to manage his blade center. I have made all ports trunk ports, and now he can't get to the management service. The VM's are still running, he just can't get to the VM that runs the VM service. He had me put everything back. This is so frustrating. i guess I need to now look at interfaces 15 and 16, the management ports. They are trunks also. Any advice for him?! He is on the line with tech support right now.

glen.grant Tue, 02/06/2007 - 10:55

15 and 16 don't need to be trunks just make those access ports in the management vlan you are using to manage the server side .

santa_cruz Tue, 02/06/2007 - 12:17

I'm using vlan 1 as the management vlan. Is that a mistake. Wow, what a mess we had this morning. I now have switchports back to access only, the MANAGER came in and said, why would we need multiple vlan's on a blade? HELLO?

Anyway, she just wanted to get the one production site back up. I'm done with this project for now. Too bad, but we do have another VM that we can use for testing. One with NO production servers on it! Thanks so much for your help on this.

Cat

Actions

This Discussion