vlans + DHCP server pool

Unanswered Question
Feb 4th, 2007

Hello,

I have a problem to configure 3 vlans , each vlan must have its own DCHP server pool

I configured the dhcp server in the router , for the voice vlan (172.16.1.0).

Now , i want to configure 2 vlan [ VLAN 1, VLAN 2] in the Switch 3550 , and each vlan must have its own pool address.

I would ask you how i can do that in the switch, and wich configuration i must do for each port in the switchs [ ipPhone + Laptop]?

many thanks

Hicham

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Sun, 02/04/2007 - 21:19

Hello Hicham,

On each port you will definitely give a voice vlan and a data vlan.. say, the data vlan 1 = 100, data vlan 2 = 200 , you will configure 2 IP DHCP pools on your 3550 and give layer 3 IP adderesses for each of these VLAN... eg

VLAN 100 Layer 3 IP - 192.168.78.1

VLAN 200 Layer 3 IP - 10.20.20.1

You can configure the following DHCP commands on your 3550:

ip dhcp excluded-address 192.168.78.1 192.168.78.10

ip dhcp excluded-address 10.20.20.1 10.20.20.10

!

ip dhcp pool testpool

network 192.168.78.0 255.255.255.0

default-router 192.168.78.1

dns-server 200.200.200.200

lease 7

!

ip dhcp pool testpool1

network 10.20.20.0 255.255.255.0

default-router 10.20.20.1

dns-server 100.100.100.100

!

Now, when a user connects from VLAN 100, the DHCP server will give an IP from 192.168.78.0, since the VLAN 100 layer 3 is defined on the switch on that range.. similar thing happens for VLAN 200... so, you can cover up many VLANs with the same switch giving the IP address...

Hope this helps.. all the best.. rate replies if found useful..

Raj

Amit Singh Mon, 02/05/2007 - 00:54

In addition to Raj's post, Please configure the switch ports as following:

Conf t

interface fa 0/1

switchport mode access

switchport access vlan 100

switchport voice vlan 200

This will work out for you and you will get the proper ip address from the respective pools.Please do not configure the switchports as trunk ports where you will connect the IP phones.Configure the ip phone ports as mentioned above.

Just configure the uplink ports between the 2 350 as trunk and do the routing for the vlans only at one of the 3550 switch.

HTH,Please rate if it does.

-amit singh

sachinraja Tue, 02/06/2007 - 15:43

Yep.. amit is right (as always) :) ..

haitham.. did you try this ? do you need anything else on this post ??

Raj

Actions

This Discussion