How to make a backup connection with ISDN for a ADSL primary connection

Unanswered Question
Feb 5th, 2007

Good afertnoon All !

I have on FastEthernet0/dialer1 a DSL Modem attached, I have write a Route and a NAT, connection to my ISP ok.

On the BRI0/dialer0, I have write a Route and a NAT, connection ok too. (for test I deleted the NAT and Route for Ether0)

After i have add in interface FastEthernet0 : backup dialer0 and backup delay 10 10.

When I manualy disconnect Fastethernet0, dialer0 come up, dial and make the connection, but no acces outside is possible.

I have try to put two NAT with same adress, but no success.

How to make the NAT and route correctly for this case?

Thanks in advance.

==========================

My config : CISCO 1712 Router

version 12.3

!

isdn switch-type basic-net3

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn spid1 xxx

isdn spid2 xxx

no cdp enable

!

interface FastEthernet0

description $ETH-WAN$

no ip address

backup delay 10 10

backup interface Dialer0

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 2

no cdp enable

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.248

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer string xxx

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

interface Dialer1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 2

dialer-group 2

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat pool Test 10.10.10.0 10.10.10.7 netmask 255.255.255.248

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source list 100 interface Dialer1 overload

!

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.10.10.0 0.0.0.7

access-list 100 remark NAT for BRI

access-list 100 remark SDM_ACL Category=2

access-list 100 permit ip 10.10.10.0 0.0.0.7 any

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

no cdp run

=============================

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Mon, 02/05/2007 - 20:37

Hi

Instead of applying backup interface and backup delay command under the fast ethernet interface can you apply the same under interface dialer 1 ?

Do remove the commands from fast ethernet interface after adding under interface dialer 1..

Since primarily you are routing the traffic via dialer 1 you need to redefine the traffic routing via dialer 0 when the main link goes down..

regds

flavien.salvador Tue, 02/06/2007 - 00:43

Hi

Thanks for your fast reply. !

No, it's no possible to assign the backup on a dialer. You can only backup a physical interface on to a dialer or on another physical, like i see...

I think i have "only" a NAT or Routing configuration problem, to say when the backup line is up (isdn) witch route to take...

I hope some more idea are comming..

Thanks

spremkumar Tue, 02/06/2007 - 00:54

Hi

Can you remove the backup commands under the fast ethernet interface and redefine your static route with some admin distance attached to it ?

Also have you ever seen whether your dialer interface goes down once you get disconnected from your SP through the primary link ?

If the dialer goes down automatically then the route which you have pointed towards the primary dialer interface will go off and the traffic will flow through the secondary dialer using the floating static route..

regds

flavien.salvador Tue, 02/06/2007 - 03:29

Hi

I have remove the backup commands under fastethernet0 and make routing like this :

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer0 10

!

ip nat pool Internal 10.10.10.0 10.10.10.7 netmask 255.255.255.248

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source list 100 interface Dialer1 overload

!

When the fastethernet come up, the bri0:1 come down, but no success to have access externaly. only if I delete : ip nat inside source list 1 interface Dialer0 overload , come my connection working....

flavien.salvador Thu, 02/08/2007 - 05:37

Good afternoon !

No body has a ideas !

I cant think i am alone to wisch make this !

Help meeee...

Thanks in advance

Actions

This Discussion