Multicast and multipoint FR interface in upstream

Unanswered Question
Feb 5th, 2007

Hi all.

I'm testing up multicast on my lab.

I've set the network as described in my beautiful file (please send kids to bed before open it) :-)

Basically, R7 is the source (simulated with a ping), where the client is connected to R2 (simulated with an ip igmp-join X.X.X.X on eth0).

R1 connects with aa FR multipoint access interface R5 and R6, thay share of cours the same subnet. traffic from R5 to R6 passes through R1 (FR static mapping with broadcast parameter enabled)

All the interfaces (but the ethernet going to receiver on R2) are set with IP PIM sparse-dense-mode.

I'm trying to set auto-rp

(R1 mapping agent and R5 RP) but with no success so far.

Now, more that: switch to sparse-mode only and enable nbma-mode on R1, I'd like to get a nice answer to understand why this is not working.

Last thing I've noticed is that if I ping the multicast group from R7 (simulating the source), the ping fails and no *,G entries with reference to the group appear in the mroute table); however, if I first ping the mcast IP from R1 (successfully) and than from R7 the ping from R7 in this case works (and I can find the *,G entries).

I know, I know lot of questions and possibly the post with the highest number of brackets on the Cisco forum so far, but belive me that I've tried and read a lot before post here.

Any help/clarification would be much appreciate.

Thanks!!

:-)

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Fri, 02/09/2007 - 10:17

PIM-DM builds source-based multicast distribution trees that operate on a "flood and prune" principle. Multicast packets from a source are flooded to all areas of a PIM-DM network. PIM routers that receive multicast packets and have no directly connected multicast group members or PIM neighbors send a prune message back up the source-based distribution tree toward the source of the packets. As a result, subsequent multicast packets are not flooded to pruned branches of the distribution tree.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca794.html#wp1001050

bellocarico Mon, 02/12/2007 - 07:17

I've actually found the problem.

It was R2 where I set an ip igmp join-group command on ethernet0/0.

This device was down, but kept up with a "no keepalive" command.

As soon as I've moved the ip igmp jpin-group from ethernet 0/0 to loopback0 it worked!

Actions

This Discussion