Inbound call failure to CCM 5.0 H323

Unanswered Question
Feb 5th, 2007

I am getting frustrated. I am setting up a LAB CCM5.0, with Meetingplace express, and Unity. I have all the internal stuff working, I can make outdound calls, but I cannot get anything to dial in. I have the gateways setup as H.323, and a dial-peer in each one for the specific DID's to point to the IP of the callmanager. I have a translation pattern that points one of the DID's to the DN of one of the phones, and route pattern that points another DID to the Meetingplace H.323 gateway. I am stuck as I dont know where to look on the system for any error messages, and I dont think I missed anything either, since we have several CCM4.2 clusters that are setup and working with inbound H.323, and I pretty much set this up the same way.

Here is a debug from the AS5350, note I stripped the phone numbers.

Feb 5 17:29:45.707: ISDN Se3/4:23 Q931: RX <- SETUP pd = 8 callref = 0x0170

Bearer Capability i = 0x8090A2

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98392

Exclusive, Channel 18

Facility i = 0x9F8B0100A10F02010106072A8648CE1500040A0100

Protocol Profile = Networking Extensions

0xA10F02010106072A8648CE1500040A0100

Component = Invoke component

Invoke Id = 1

Operation = InformationFollowing (calling_name)

Name information in subsequent FACILITY message

Calling Party Number i = 0x2181, '847xxxxxxx'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '847xxxxxxx'

Plan:ISDN, Type:National

Feb 5 17:29:45.731: ISDN Se3/4:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8170

Channel ID i = 0xA98392

Exclusive, Channel 18

Feb 5 17:29:45.759: ISDN Se3/4:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x8170

Cause i = 0x80A6 - Network out of order

Feb 5 17:29:45.847: ISDN Se3/4:23 Q931: RX <- RELEASE pd = 8 callref = 0x0170

Feb 5 17:29:45.847: ISDN Se3/4:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8170

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kelvin.blair Mon, 02/05/2007 - 09:54

On your gateway configuration in CM how many digits are you allowing. Is it the default of all? If so, make sure you are translating the exact digits to the extension. If you see 847xxxxxxx coming in bound and a dialpeer is setup to forward to the ip address of CM in which is setup to accept all digits a translation rule needs to match 847xxxxxxx and called part go to extension.

tahequivoice Mon, 02/05/2007 - 10:25

Yes, they are set to all digits, which is 10 on the dial peer. The translation rule matches the 10 digits, and points to a 4 digit extension. I dont know where to look on this call mangler to find error logs to see what is happening. I have full connectivity between the gateways and this server, and I can make outbound SIP calls through this same gateway.

tahequivoice Mon, 02/05/2007 - 10:43

NM I found I have to download and install the RTMT to view the traces. DOH!

Here is something else that is odd. In the help section, it says to go to tools>trace>etc, but when I go to tools, there is no trace available. Whats up with that?

tahequivoice Mon, 02/05/2007 - 11:56

Here is something else I found. If I set the callmanager service parameter for H323 Accept unknown TCP connection to true, I now get a fast busy, so I at least know I am getting the call to the callmanger, but it doesnt know what to do with it from there I guess.

tahequivoice Fri, 02/09/2007 - 09:18

Found the problem. Accept unknown tcp connections was set to false, set it to true and the calls came into the system.

mgroeneweg Mon, 04/16/2007 - 00:50

Where is this setting? "Accept unknown tcp connections"... I've got a similar issue, and my Callmanager 5.1 is not accepting calls from a fongiured gateway (although I still suspect a CSS issue).

tahequivoice Mon, 04/16/2007 - 04:49

I will need to look it up, it has been a while. I found it under the configuration settings for the server itself, but where exactly I dont remember. I will post back when I get a chance to go through it again.

kelvin.blair Mon, 04/16/2007 - 04:51

I'm not sure about 5.1, but under 4.2.3 and 4.1.3 it was located un Call Manager Service Parameters.

mgroeneweg Mon, 04/16/2007 - 05:51

Yep, this is where I thought it would be as well... but CCM5.1 is a different beast.

From the Help page, for the 'System -> Enterprise Paramters' page...

"You cannot add or delete enterprise parameters, but you can use the following procedure to update existing enterprise parameters."

The procedure mentions TAC advise, or specific paramters if flagged. In my basic CCM5.1, there's nothing so far.

tahequivoice Mon, 04/16/2007 - 06:00

OK found it, go to System>service parameters>Cisco Callmanager

Scroll down to Clusterwide Parameters (Device - H323)

First line is the one to change.

mgroeneweg Mon, 04/16/2007 - 06:15

Thanks, but I'm not seeing that as an option. Not sure if it's the 5.1 way, or whether my setup is broken.

I've put a TAC case in, see what Cisco have to say.

Actions

This Discussion