CE network module

Unanswered Question
Feb 5th, 2007

Hi all,

Need your help to troubleshoot the problem when configuring Content Engine Network Module. This is my first experience configuring the CE. I am using ISR 2821, IOS version 12.4 and ACNS version 5.5.3.

The environment is a college university. There have three (3) campuses. The ISR and the CE network module are behind the firewall and using static NAT configured in the firewall to go to the Internet. The policies for the static NAT is only allowed http and https. Each site is configured using the same concept.

The service running on the CE network module is only standard web cache and redirection on port 80 only. The WCCP version enable is version 2.

I do not have a problem when configured CE network module on College A and look that the CE is working properly. They have student, admin and IT vlan. Only the student vlan is using proxy server to access the Internet. Until now the CE is running and I do not receive a complaint from them.

When I am configuring the same CE network module on College B, for the first 10 minutes it is working properly. Suddenly, the access to the Internet becomes intermittent. All the student, admin and IT vlan cannot access the Internet. After 5-10 minutes the line is back to normal and it always repeating. College B environment is little bit different because they have another routers in between.

College A : User > Access switch > ISR 2821 + CE > Firewall > Internet

College B : User > Access switch > Router > Router > ISR 2821 > Firewall > Internet

College A

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

no service password-encryption

hostname ABC

boot-start-marker

boot-end-marker

no aaa new-model

resource policy

ip wccp web-cache

ip cef

ip name-server 192.9.201.1

interface GigabitEthernet0/0

description P2P Connection to DEF

ip address 192.168.111.1 255.255.255.240

duplex auto

speed auto

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface FastEthernet0/0/0

description Connection to ABCswitch

switchport mode trunk

!

interface FastEthernet0/0/1

description Connection to P2P

switchport access vlan 14

!

interface FastEthernet0/0/2

description Conncetion to FIREWALL

switchport access vlan 4

!

interface FastEthernet0/0/3

!

interface Content-Engine1/0

ip address 192.9.111.1 255.255.255.0

service-module ip address 192.9.111.2 255.255.255.0

service-module ip default-gateway 192.9.111.1

!

interface Vlan1

ip address 192.9.100.15 255.255.255.0

!

interface Vlan4

description Connection to FIREWALL

ip address 192.9.192.10 255.255.255.0

ip wccp web-cache redirect out

!

router ospf 1

log-adjacency-changes

network 192.9.100.0 0.0.0.255 area 0

network 192.9.102.0 0.0.0.255 area 0

network 192.9.200.0 0.0.0.255 area 0

network 192.9.201.0 0.0.0.255 area 0

network 192.168.111.1 0.0.0.0 area 0

default-information originate always

!

no ip classless

ip route 0.0.0.0 0.0.0.0 192.9.192.11

!

ip http server

no ip http secure-server

!

CE network module

! ACNS version 5.5.3

!

!

hostname ContentEngineABC

!

http cache-cookies

http proxy incoming 80

http tcp-keepalive enable

!

ip domain-name abc.edu.com

!

interface FastEthernet external

shutdown

exit

interface FastEthernet internal

ip address 192.9.111.2 255.255.255.0

exit

!

ip default-gateway 192.9.111.1

!

no auto-register enable

!

ip name-server 192.9.201.1

!

wccp router-list 1 192.9.111.1

wccp web-cache router-list-num 1

wccp version 2

!

username abc password xxx

username abc privilege 15

!

authentication login local enable primary

authentication configuration local enable primary

! End of ACNS configuration

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion