Routing Issue?

Unanswered Question
Feb 6th, 2007

Hi,

The client(Client A) router is configured with

interface FastEthernet0

ip address 172.20.96.2 255.255.240.0

On my router(3600) I am advertising 172.20.96.0 /20 and I am routing it back to the client via the interface(s1/0) they connect to on my router.

Here is the problem. I have another client(ClientB) connected to another serial interface(2/0) on the same router this client connects to but what ppl coming from the 172.20.110.0 /24 range(Client A network) are not able to connect to that the device. They do a traceroute to the device and it times out on the Fe.

The funny is though that ppl from 172.20.96.0 - 172.20.99.255( Client A network) are able to connect to this device.

I have spoken to Client B and they are not seeing any connections hitting their firewall from the 100-110 range.

What am I missing? There is no route statement on the Client A router to say ip route (client B device)via serial0 which is the entry point into my network.

Please help? Been on this for two days now.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Tue, 02/06/2007 - 04:09

Hi Brad

Can you post the config of the router as well the trace results here ?

regds

bradlesliect Tue, 02/06/2007 - 04:39

config as requested. If I do a show ip route for the host on Client B network that Client A is trying to connect to, the network is not in the table BUT yet some of Client A's networks can connect to that host. How is that possible?

Attachment: 
sachinraja Tue, 02/06/2007 - 04:15

Arent the subnets overlapping.. can u do a show ip route at both the ends for specific hosts and see if they are going towards the correct next hops ??

Raj

bradlesliect Tue, 02/06/2007 - 04:35

Yes they are overlapping. Both subnets are part of a /20 network which is part of 172.20.96.0 /20.

If I do a show ip route to anything on 172.20.96.* and up, everything goes via the Fastethernet.

I will post the config for client A router now. I dont manage client B router so cant help you with config there.

smothuku Tue, 02/06/2007 - 04:30

Hi ,

I guess your setup is as follows.

Client A --------s1/0 Myrouter s2/0--Client B.

F0:

172.20.96.2 /20

And route 172.20.96.0 255.255.240.0 s 1/0 is added in myrouter.

1.What is the ip addresses used on myrouter and client B.

2.can you paste show ip route 172.20.96.2 from myrouter and client B.

Can you explain us briefly about your setup once again.

Have you configured client B route as well as myrouter route on client A router ?

same on myrouter and clent B also.

IMP : each and evry router should have two static routes pointing to either directions.

Thanks,

satish

bradlesliect Tue, 02/06/2007 - 04:44

sh ip route 172.20.96.2

Routing entry for 172.20.96.0/19

Known via "static", distance 1, metric 0 (connected)

Redistributing via ospf 2

Advertised by ospf 2 subnets

Routing Descriptor Blocks:

* directly connected, via Serial1/0:8

Route metric is 0, traffic share count is 1

The last 2 requests you lost on.

wrt static routes - there is no static routes on client A router or myrouter telling it how to get to that device on client B network.

smothuku Tue, 02/06/2007 - 05:11

Hi ,

what is the purpose of the following ip route

ip route 172.20.100.0 255.255.255.0 172.20.96.100 on client A.

172.20.96.100 belongs to which interface.

Thanks,

Satish

smothuku Tue, 02/06/2007 - 05:26

Hi ,

Remove the above mentione route and check the issue once again.

Thanks,

satish

bradlesliect Wed, 02/07/2007 - 01:22

are you saying that :

ip route 172.20.100.0 255.255.255.0 172.20.96.100

could be causing the problem .....if so why?

Actions

This Discussion