QoS

Answered Question
Feb 6th, 2007

I have two routers cisco 2801 with VoIP between them.

I used the following interface config for qos:

interface FastEthernet0/0

ip address 10.84.243.1 255.255.255.0

duplex auto

speed auto

auto discovery qos

interface Serial0/3/0

bandwidth 64

no ip address

encapsulation ppp

auto qos voip trust

auto discovery qos

no fair-queue

ppp multilink <---- Automatically generated

ppp multilink group 2001100116 <---- Automatically generated

After applying the commands "auto discovery qos" and "auto qos voip trust"

on Ethernet and Serial Interfaces, it generated the following commands:

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 70

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default

fair-queue

interface Multilink2001100116

bandwidth 64

ip address 10.245.2.210 255.255.255.248

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

ppp multilink group 2001100116

service-policy output AutoQoS-Policy-Trust

ip rtp header-compression iphc-format

How do I change the policy map configuration (auto configured)? I am new to this QoS.

I have this problem too.
0 votes
Correct Answer by mheusinger about 9 years 7 months ago

Hi,

afaik the autogenerated config can be modified like any other policy-map.

As a good starting point for general QoS design and options have a look at the "Enterprise QoS Solution Reference Network Design Guide Version 3.3"

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf

In your case you can implement additional classes and asign resources to them. Just keep in mind, that per default only 75% of the interface bandwidth can be used in a policy-map for guaranteed bandwidth.

An example of a modified policy to highlight, what I mean:

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

class-map match-all FTP

match protocol ftp

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 60

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class FTP

bandwidth percent 10

class class-default

fair-queue

random-detect

Again 75% are allocated to the relevant classes. I took something from the VoIP class to give it to FTP. This might or might not be suitable in your environment and should just demonstrate the principle.

Hope this helps! Please rate all posts.

Regards, Martin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
mheusinger Tue, 02/06/2007 - 05:58

Hi,

afaik the autogenerated config can be modified like any other policy-map.

As a good starting point for general QoS design and options have a look at the "Enterprise QoS Solution Reference Network Design Guide Version 3.3"

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf

In your case you can implement additional classes and asign resources to them. Just keep in mind, that per default only 75% of the interface bandwidth can be used in a policy-map for guaranteed bandwidth.

An example of a modified policy to highlight, what I mean:

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

class-map match-all FTP

match protocol ftp

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 60

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class FTP

bandwidth percent 10

class class-default

fair-queue

random-detect

Again 75% are allocated to the relevant classes. I took something from the VoIP class to give it to FTP. This might or might not be suitable in your environment and should just demonstrate the principle.

Hope this helps! Please rate all posts.

Regards, Martin

Actions

This Discussion