Unable to establish BRI call

Unanswered Question
Feb 6th, 2007

Hi,

I am trying to connect my 2811 to HiCom 150 via BRI. VIC2 - BRI-NT/TE is installed into 2811. I am using QSIG.

I cannot establish outgoing call from Cisco to HiCom with csim.

The ISDN portion seems to be Ok.

#sh isdn status BRI 0/0/0

Global ISDN Switchtype = basic-net3

ISDN BRI0/0/0 interface

dsl 0, interface ISDN Switchtype = basic-qsig

**** Slave side configuration ****

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Here is BRI config:

interface BRI0/0/0

no ip address

isdn switch-type basic-qsig

isdn overlap-receiving

isdn point-to-point-setup

isdn incoming-voice voice

isdn skipsend-idverify

voice-port 0/0/0

compand-type a-law

bearer-cap Speech

But the call cannot be established. The reason is "Invalid information element contents"

Here is complete debug:

#csim start 7122

csim: called number = 7122, loop count = 1 ping count = 0

csim err csimDisconnected recvd DISC cid(19)

csim: loop = 1, failed = 1

csim: call attempted = 1, setup failed = 1, tone failed = 0

*Feb 6 14:12:25.070: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x17 is 0x0 0x0, Called num 7122

*Feb 6 14:12:25.070: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8 callref = 0x000F

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Called Party Number i = 0x80, '7122'

Plan:Unknown, Type:Unknown

*Feb 6 14:12:25.106: ISDN BR0/0/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x800F

Cause i = 0x85E418 - Invalid information element contents

What can be the cause of such behaviour?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
fmeetz Mon, 02/12/2007 - 06:50

This message "invalid information element contents" only shows up during debug q931 enabled. doesn't seem to impact the call connection.

Actions

This Discussion