IP Communicator (2.0.2.0) has no audio over VPN connection

Unanswered Question
Feb 6th, 2007

IP Communicator v 2.0.2.0

CDP v2.0.1.01

Media Driver v 2.0.1.08

Windows XP SP2

VPN Client: Microsoft PPTP

VPN Server: Microsoft ISA 2004

I am trying to get CIPC to work remotely. I am connecting via PPTP VPN, and I have absolutely confirmed ACLs are not blocking traffic. CIPC will register with Call Mgr, but there is no voice audio.

If I call from the laptop, there is no ring audio. I have checked the audio config in Call Mgr and confirmed the audio is working on my laptop.

Also - I have taken the laptop to a office that has a site-to-site VPN with Call Mgr and CIPC on my laptop works. But it will not work when I an connected via VPN from home.

Any suggestions?

-Kevin

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
joshuaharrington Wed, 02/07/2007 - 09:37

I too have the same issue. Here is my setup:

IP Communicator v 2.0.2.0

CDP v 2.0.1.01

Media Driver 2.0.1.08

Windows XP SP2

VPN Client: Cisco VPN Client 4.8.02.0100

VPN Server: Cisco VPN Concentrator 3005

When I connect my laptop to my corporate LAN, and fire up IPCommunicator, everything works great. I can recieve calls, place call, check voice mail, anything I can do with my 7961 on my desk. However, once I take my laptop home, and connect over the VPN, the IPCommunicator no longer has any sound when making/receiving calls. I can get dail tone, even listen to Unity prompts. Anyone have any quick ideas as to what to look for to start with?

Regards,

-Joshua

jgs1393 Thu, 02/08/2007 - 05:43

I have the same problem. I can hear the signaling tones, dial tone ring tone etc.. Also I'm sure that IP Communicator is connecting to the phone I am calling but there is no audio in either direction.

Matthew Bryant Thu, 02/08/2007 - 12:01

Can you ping the phones you are trying to connect to? We had some routng issues before with the vpn concentrators not knowing the routes to the phone vlans.

Sounds like you have a route to the CallManager, but once your call gets set up, you have no voicepath to the phones.

You should be able to ping all your voice vlans from your vpn connection.

KEVIN BUCHANAN Thu, 02/08/2007 - 12:46

Yes, I can ping. I have checked the firewall (both sides) and the router (between the call manager and the firewall)...routing is correct, because I can ping between them. As for the ACLS, I have tested an ACL list with an "permit ip any any"...and it doesn't work. I have checked the logs, and no packets are denied.

kendo.igor Thu, 02/08/2007 - 15:39

This is how I resolved this issue in our environment

Establish a VPN connection

Make a note of the IP address assigned to you by VPN

Right click on IP Communicator > Preferences > Audio Tab > Nework... > "Use this address" and type in the IP address assigned to you by VPN.

Close and reopen IP communicator.

It should work now.

KEVIN BUCHANAN Fri, 02/09/2007 - 04:17

Sorry, I should have mentioned - I have already dont that and it still doesn't work.

I watched the log files and saw that CIPC was using the local address - so, I changed it to use the VPN assigned address.

The interesting thing is that I don't see any packets being denied anywhere. When the VPN is connected, I can ping from CIPC to Call Mgr, and from Call Mgr to CIPC. I have monitored the VPN firewall and the router on the other side of the firewall...there isn't any messages logged about denying packets. I have disabled the local Windows XP SP2 firewall, so I can't see where the breakdown is happening!!

Thanks for the suggestion.

-Kevin

johnnylingo Thu, 03/01/2007 - 09:10

Same problem here. CallManager 4.1(3)sr4, IP Communicator 2.0.2, VPN client 4.8.02

I have a user setup to register using the MAC on their local PC, which has the address 192.168.1.100. It registers fine, the problem of course is since that is their local LAN and not in our routing table, RTP traffic fails to be routed properly.

I'm assuming they want to register using the Virtual VPN adapater rather than the LAN NIC. However, this causes two problems:

1) Using the VPN adapter to register with CallManager doesn't work, because all the VPN clients use the same virtual MAC address (00-05-9A-3C-78-00).

2) Setting CIPC to use the VPN adapter for audio streams under Menu -> Preferences -> Audio -> Network doesn't seem to have any effect. A packet sniffer revealed the RTP packets are still sent to 192.168.1.100 rather than the address of their VPN adapter. Also, the IP address pulled by the VPN client is DHCP, so manually entering an address for audio under really isn't an option for us.

So, I see where the breakdown is happening, but don't know what the fix here is.

johnnylingo Wed, 03/07/2007 - 09:04

I ended up getting it working fine with the following two settings under Preferences:

1) On "Network" tab, choose "Use this Device Name". Should auto-populate to SEP+MAC of first NIC. Set this as the Device name in CallManager.

2) On "Audio" tab, "Network" button, choose "Use this adress:". Should auto-populate to IP Address currently used by the VPN adapter.

After OKing out, completely close down IP Communicator and restart.

I didn't think this would work well since we use DHCP for VPN address, but upon re-connecting to the VPN it picked up the address change just fine and I had 2-way audio.

Actions

This Discussion