HELP ! This is an URGENT mystery!

Unanswered Question
Feb 6th, 2007

What do you think would cause this output?

On a leaf switched connected to CORE1 and

CORE2....

6509-server-NY-02#sh mac-addr int g8/42

Legend: * - primary entry

age - seconds since last seen

n/a - not available

vlan mac address type learn age ports

------+----------------+--------+-----+----------+--------------------------

* 19 000b.cd9a.cfaf dynamic Yes 0 Gi8/42

6509-server-NY-02#sh mac-addr addr 000b.cd9a.cfaf

Legend: * - primary entry

age - seconds since last seen

n/a - not available

vlan mac address type learn age ports

------+----------------+--------+-----+----------+--------------------------

Supervisor:

* 17 000b.cd9a.cfaf dynamic Yes 35 Po15

* 16 000b.cd9a.cfaf dynamic Yes 25 Po14

* 19 000b.cd9a.cfaf dynamic Yes 0 Gi8/42

* 21 000b.cd9a.cfaf dynamic Yes 115 Po15

* 30 000b.cd9a.cfaf dynamic Yes 195 Po14

* 14 000b.cd9a.cfaf dynamic Yes 85 Po14

Supervisor:

* 17 000b.cd9a.cfaf dynamic Yes 35 Po15

* 16 000b.cd9a.cfaf dynamic Yes 25 Po14

* 19 000b.cd9a.cfaf dynamic Yes 0 Gi8/42

* 21 000b.cd9a.cfaf dynamic Yes 115 Po15

* 30 000b.cd9a.cfaf dynamic Yes 195 Po14

* 14 000b.cd9a.cfaf dynamic Yes 85 Po14

Po14 is a trunk to core#1

Po15 is a trunk to core#2

All switches have a consisent root,

All switches have working trunks, with

no native vlan mismatch

All SVI's are working correctly

the CORE's have a trunk to each other

(on both Po1). that is a trunk allowing all production vlans...

I'm really stumped. the result is connectivity outages for a few seconds as the mac is known via the wrong vlan.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sachinraja Tue, 02/06/2007 - 21:52

what exactly is connected on 8/42 ?? Is it a server or any other network device ?? Are you doing an Active/Active NIC card configuration, with the server connecting to both the core switches and bundled with a single virtual IP address ?? If it is so, pls remove it and do an active/standby on your server NIC card...

Raj

jbrunner007 Tue, 02/06/2007 - 22:51

server, with one nic card...

tac asked me the same problem. I went and looked at the server... one nic. here is G8/42's config

interface GigabitEthernet8/42

description PRINT23

no ip address

switchport

switchport access vlan 19

switchport mode access

spanning-tree portfast

end

sachinraja Tue, 02/06/2007 - 22:57

Its a straight forward configuration... it shold not have any issue.. did u try clearing the arp cache ?? does this populate all the entries again ??? it will be good if you tell us more about ur network...

Raj

jbrunner007 Tue, 02/06/2007 - 23:11

I have attached a diagram of our environment.

Here is the config of G8/42 on the 14th_servers switch. the same switch that is learning an attached server's mac via its trunk links... I'm still stumped...

!

interface GigabitEthernet8/42

description PRINT23

no ip address

switchport

switchport access vlan 19

switchport mode access

spanning-tree portfast

end

Attachment: 
lgijssel Wed, 02/07/2007 - 01:38

It would be very nice to find out to which device the mac adress belongs.

Can it be possible that this is a Cisco layer3 switch?

It is a less well-known feature that cisco uses the same mac adress for all vlan interfaces on a switch.

Normally, this is no problem as the mac adress only needs to be unique within a layer2 network (i.e. vlan)

Regards,

Leo

uhaskamp Mon, 08/06/2007 - 21:40

Hi Joseph,

did you find a solution for your problem?

I ask because I have a similar problem between two Cat6500 with Sup720.

I see a mac address, it's the mac-address of an access switch, jumping from vlan1 to vlan100. This happens between the two Cat6500 over the port-channel they are connected with.

Regards,

Udo

cdusio Tue, 08/07/2007 - 07:16

What version are you running?

Do you have any service modules in these 6500's?

I ran into an issue where I had to force bus mode switching on the 6500.. Had a similar issue.

http://www.ciscotaccc.com/kaidara-

advisor/lanswitching/showcase?case=K39045750

HTH

Chris

ilnaiduccna Tue, 08/07/2007 - 09:42

as chris said, what version are you running?

Did the 6500's are internal connected to others?

uhaskamp Tue, 08/07/2007 - 21:29

Hi,

we are using 12.2(18)SFX7. And yes we are using a CSM in the Cat6500.

I had a look on the case/bug notes in your link. So this issue should be fixed with our software and the CSM is working in bus mode as the Sup. The other cards are working in dcef mode. These boards are 68xx modules with WS-F6K-DFC3B on it.

We are using an etherchannel between the two Cat6500 which is build over two modules.

Any idea?

Udo

Actions

This Discussion