MWI Customization

Unanswered Question
Feb 7th, 2007

We are now using Unity 4.2(1) integrated with Traditional PBX. I found that MWI behaviour is that it only send MWI-On to subscriber for the 1st new message. We encountered some cases that the the Message Lamp was not lighted for the 1st message. After that, he/she got many voice messages and he/she was not notificed by MWI.

Is there any setting that the system can send MWI-On for every new message (for particular user)? Thanks!

P.S. we already set the system to send MWI-On/Off twice for every notification

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mrmccann Wed, 02/07/2007 - 00:32

There is no way to have Unity send MWI-On for every new message. You should investigate further why MWI is not lit on the first try sometimes. This troubleshooting guide will give you something to start with:

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_troubleshooting_guide_chapter09186a00801ba5fb.html

The behavior you report is quite odd, you should confirm that MWI works at all for the subscribers where it doesn't seem to be working "on the 1st try". It could be that subscribers are not configured properly for MWI. It also would be good to confirm whether Unity is actually sending the MWI request out on the first message. If it is sending it out, then there is something going on with the PBX. If it is not getting sent out, you need to investigate on the Unity side.

If you can't figure out the root cause of this problem, a partial workaround might be to schedule a daily MWI resynch - instructions are at the end of the guide at the link above.

j.dyer Wed, 05/16/2007 - 15:31

How/where did you set the system to send MWI on/off twice for each notification? I'd like to try that to see if it will help resolve some of the MWI issues i'm having with my Nortel Integration...

was it by changing the RetryCount parameter in the INI file? If so, which INI file are you using (ie what kind of integration is it).

Thanks!

John

Actions

This Discussion