Option 150 Problem

Unanswered Question
Feb 7th, 2007

I have CCM 4.1(2) and using 3750 switches for DHCP. I often have this problem that when my phones (7912G) boot up, there directory services option is missing although the TFTP server IP (CCM in my case) is mentioned in dhcp configuraton under dhcp option 150. What I do is to delete the dhcp pool from the switch, clear the dhcp bindings and arp cache, re-insert the dhcp pool and restart the phone. This always bring back the dc directory option. Any solution to this? Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Wed, 02/07/2007 - 03:21

Would you check that you are running the latest firmware on the 7912? Should be

CP7912080002SCCP060817A.sbin

Here is a copy of my pool off my 3750

ip dhcp excluded-address 10.153.5.1 10.153.5.16

ip dhcp excluded-address 10.153.33.1 10.153.33.16

ip dhcp excluded-address 10.153.5.255

!

ip dhcp pool PC's

network 10.153.5.0 255.255.255.0

default-router 10.153.5.1

dns-server 10.150.1.31 10.11.1.30

!

ip dhcp pool VOIP-PHONE

network 10.153.33.0 255.255.255.0

default-router 10.153.33.1

option 150 ip 10.153.32.16 10.153.32.17

!

!

interface GigabitEthernet1/0/1

switchport access vlan 105

switchport mode access

switchport voice vlan 133

no logging event link-status

no logging event power-inline-status

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

!

IOS c3750-ipservicesk9-mz.122-25.SEE2

Paolo Bevilacqua Thu, 02/08/2007 - 03:53

As I said I would upgrade the phone firmware because many troubles are caused by bugs in that.

sheerazkhatri Thu, 02/08/2007 - 21:00

Let me try upgrading the firmware. Once I had the problem of not picking up the IP from DHCP by 7936 conference stations. I upgraded the firmware and that resolved my problem.

Actions

This Discussion