1700 router factory reset

Answered Question
Feb 7th, 2007

Hi-

I've got a Cisco 1720 router that I need to factory reset. I can connect to the console using hyperterminal (9600, 8N1). I reboot the router using the switch, then ctrl+break. I'm given a rommon 1> prompt. However, I can't seem to type the necessary confreg 0x2102

I've even tried turning on echo.

Any ideas???

THANK YOU

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
weinberk1 Wed, 02/07/2007 - 09:45

Thanks for taking the time to reply!

I saw that link already. The problem is that when I'm at that first rommon 1 prompt, I can't seem to type anything.

I assumed it was a local echo problem, so I tried just entering confreg 0x142 (and others) followed by return. Nothing happens.

weinberk1 Wed, 02/07/2007 - 09:50

I've tried just confreg [enter]

Nothing appears at the rommon 1 > prompt and no settings are displayed on screen. Just to make sure that I was still connected, I did another ctrl+break and get:

rommon 1 >

*** Reserved LVL 7 Interrupt ***

PC = 0xfff0b9c0, Vector = 0x500, SP = 0x80004de4

So I'm connected, but it doesn't seem like my other keystrokes are getting to the router when in rommon 1 >

If I let the device boot without ctrl+breaking, I am prompted for the username and password. I can type these in and the characters appear on screen.

I'll have to mull this a bit. If you're sure that Hyperterm is setup right (i.e. confirm it by accessing another Cisco Box console port)8 N 1 no flow control, then you may have corrupt ROM issues. The bottom line is that without rommon 1 interaction, you have no method of forcing base maintenance actions. And the only failed rommon issues I have ever run across are called into TAC and the subject unit replaced.

weinberk1 Wed, 02/07/2007 - 10:02

I'm going to give this a try on another 1700 router that we're going to have to do this on anyway. I'll get right back with you.

Thanks

weinberk1 Wed, 02/07/2007 - 10:06

I HATE HYPERTERMINAL and appologize for wasting your time. I tried using MTTTY, configured the same way 9600,8,n,1 no flow, and viola, confreg works.

Thank you so much for working through this with me.

Actions

This Discussion