Unroutable?

Unanswered Question
Feb 8th, 2007

I am hoping someone can give me a clue on where to look next. This is a 2610 connected directly (via crossover) to a cellular internet device. With the device set to offer the public cellular net assigned IP via DHCP, the router works fine. However, with the device set to offer a private IP, the address is assigned, and the arp table populated but the router can't route to/through it. The config and some debug/show command outputs are attached. Any help would be greatly appreciated!!

I will try to better explain. The device directly connected to the ethernet port via crossover cable is an Airlink Raven. It is an EVDO Internet access device with a single Ethernet port. The device offers 2 options for the internal lan host/s. DHCP, offering a private IP address, which it then NATs to the public address it was assigned when it powered up and registered on the cellular network. Or, it can pass the public address to the internal host (router) via DHCP. I have about 220 of these devices currently deployed using the private addressing scheme. Unfortunately, I have a hand full doing what I have posted above. They are all using 2610 and 2610XM routers with IOS versions 12.3-10 and 12.3-12b. I have included the DHCP output as well as the routing and ARP table to show that the Raven device does indeed assign a DHCP address and gateway(itself). What really concerns me is that even when I try and ping the Raven device at 192.168.13.31, the debug reports "unroutable". I don't see how this can be possible as the device is directly connected and defined in the arp table and is the gateway which just assigned the address to the Ethernet. I first tried to blame this on the Raven devices, but now after some debugging, I believe it to be a router issue due to the "unroutable" output. Only a few seem to have this problem (~10 of 200+), and it goes away if I set the Raven device to assign the public address via DHCP to the router. Unfortunately, I really need to use the private addressing internally. I hope this helps to explain a little better. Again, thanks for your time.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cdowdy Fri, 02/16/2007 - 07:49

Thank you for your response! I am not able to view a routing table/arp table on the raven device but is does properly assign an address to the router via dhcp. I reviewed the page you posted as I was under the impression that "unroutable" meant that the router itself could not forward the packet. Unless I misread something, the page you refer to also seems to support this.

cdowdy Wed, 02/21/2007 - 08:22

Thanks for the reply. I just tried the ip route as described in the doc and unfortunately it made no difference as far as the unroutables. It would seem that specifying the interface in the route would be especially useful when there are multiple dhcp interfaces on the router. Unfortunately the routing table stays the same as it was in the docs I posted to the thread, and the destination address is still reported as unroutable. Bummer!

rtanner Wed, 02/21/2007 - 13:45

clutching at straws, but ... did you remove the old static route and put in the new one?

cdowdy Wed, 02/21/2007 - 14:16

Well, there are only 2 pieces of hardware concerned. The Airlink Raven EVDO internet device, and a 2610 directly connected via ethernet x-over cable.

rtanner Wed, 02/21/2007 - 14:12

A couple of things bother me - your debug output does not quite match the "expected" ( based on the Cisco doc.) nor does the routing table ( the next hop is not "connected" but via itself - which when doing a recursive lookup will not actually go anywhere).

The Raven does not seem to provide DHCP option 3 - default gateway ...

can you provide the output of

"debug dhcp detail "

to see if it gives us any more clues?

rtanner Wed, 02/21/2007 - 14:56

this sounds simliar-ish to what you are experiencing. As I always say, if in doubt reboot, then upgrade!

CSCsa53829 Bug Details

Headline DHCP client adds route with incorrect DHCP server address

Product IOS

Feature DHCP Duplicate of

Severity 3 Severity help Status Resolved Status help

First Found-in Version 12.3(12.1)T, 12.3(12.10)T All affected versions First Fixed-in Version 12.4(1.4), 12.3(14.13), 12.4(1.8)T Version help

Actions

This Discussion