Disable vad on 7912 cisco phone

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Thu, 02/08/2007 - 09:41

Hi Philippe

Please refer to the followling description and the URL for the document,

VAD configuration can be configured through the 'audiomode' parameter:

#

-----------------------------------------------------------------------------

# Parameter: AudioMode

#

# Type: bitmap value

#

# Description: Used for controlling or fine-tuning certain audio features #

# Options: Bit Values

# -----

--------------------------------------------------------

# 0 Silence Suppression in G.711

# 0 = Disable silent suppression in G.711

# *1 = Enable silence suppression in G.711

#

# 1-3 RESERVED. Must be set to 0.

#

# 4-5 DTMF Transmission Method

# 0 = Always inband

# *1 = Negotiated via SDP

# 2 = Always out-of-band

#

# 6-31 RESERVED. Must be set to 0.

#

# Defaults are marked with *.

AudioMode:0x00000011

See also:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_ipphon/english/ipp79

05g/addprot/sip/7905sch8.htm#wp1075121

I hope this can answer your question.

Thank you for your answer, but it did not fix my phone trouble. In fact, i have to disable voice detection in order to always let the voice pass through the phone.

At the moment, when i call an extension with my sip 7912 phone and the called person has answered, i do not hear his voice. I have to talk in my 7912 phone to establish the communication, and then everything goes nice.

So, i would like to shutdown voice detection or change the voice detection threshold.

regards.

Philippe.

Paolo Bevilacqua Fri, 02/09/2007 - 07:01

Hello,

The info (excellent as always) provided by gogasca indeed it is telling you how to disable VAD by the use of a configration file. You will a small package on (available to CCO registered users) that contains an utility used to generate the binary config, a tagging file needed by the same. Also incuded, bmp to logo utility.

Hi all, and thank you for you help.

I found the soluce by making changes to my configuration file. I post it here so that it can help someone else ;-)

----- cut here -----

#txt

UIPassword:

upgradecode:3,0x601,0x0400,0x0100,,69,,

dhcp:1

Proxy:

UID:

PWD:

LoginID:

UseLoginID:1

SIPPort:5060

SIPRegInterval:3600

SIPRegOn:1

AudioMode:0x00000010

NumTxFrames:2

ConnectMode:0x00000010

TimeZone:20

NTPIP:

UseTftp:1

CfgInterval:60

TraceFlags:0x00000000

DialPlan:911|1>#t8.r9t2-|0>#t811.rat4-|^1t4>#.-

RingOnOffTime:2,4,25

DialTone:2,31538,814,30831,2032,0,0,0,0,0,0

DialTone2:2,30743,1384,29864,1252,0,0,0,0,0,0

BusyTone:2,30467,1104,28959,1404,1,4000,4000,0,0,0

ReorderTone:0,2,30467,1104,28959,1404,0,0,1,2000,2000,0,0,0,0,0,0

RingBackTone:2,30831,2032,30467,1104,1,16000,32000,0,0,0

CallWaitTone:1,30831,2412,0,0,1,2400,2400,0,0,4800

MediaPort:16384

SigTimer:0x00000064

VoiceMailNumber:

DisplayName:

ShortName:0

TimeFormat:h:ia

DateFormat:m/d/y

CallWaiting:1

AttendedTransfer:1

BlindTransfer:1

Conference:1

----- cut here -----

Actions

This Discussion