Upgrading IOS on a 4507

Answered Question
Feb 8th, 2007

I need to upgrade the IOS on a 4507 to support the new WS-4248-RJ45V. It currently has:

IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-I9S-M), Version 12.1(19)EW1,

EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

I need at least 12.2(18)EW. That version is only available as ED and DF and I was assuming that since I need to upgrade this that I should upgrade to the latest version of GD which is 12.2.40. I downloaded c4500-boot-mz.122-40.bin and uploaded it to bootflash but got the message:

%Warning: File not a valid executable for this system

The MD5 hash matches after I said to upload it anyway but now I am weary of actually trying to use this image. Can anyone tell me if I got the right image file for my 4507? The supervisor in mod 1 is a Super II (1000BaseX (GBIC) Supervisor(active) WS-X4013+).

Thanks for any info provided!

I have this problem too.
0 votes
Correct Answer by Ahmede about 9 years 7 months ago

c4500-boot-mz.122-40.bin is not an IOS that you can use, it's for ROMMMON..

Get 12.2.25 EWA8 do not use EWA7, I had many problem with it and had to downgrade to EWA4 again..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
shinedog74 Thu, 02/08/2007 - 11:03

I should probably add that the file size between the original bin and the new bin are 3004156 vs. 9044204 respectively so I am assuming that this is not the correct image for my 4507. I'm currently downloading 12.2.18-EW7(ED) and the file size is much closer to the original, going to try uploading that in a few minutes here.

Correct Answer
Ahmede Thu, 02/08/2007 - 11:08

c4500-boot-mz.122-40.bin is not an IOS that you can use, it's for ROMMMON..

Get 12.2.25 EWA8 do not use EWA7, I had many problem with it and had to downgrade to EWA4 again..

shinedog74 Thu, 02/08/2007 - 12:03

Ahhh, I see now. I was also slyly hoping for a recommendation on which image to use :D

Thanks for the help!

Actions

This Discussion