IP Communicator "services button" doesn't work!

Unanswered Question
Feb 8th, 2007

We have a number of laptops with IP Communicator 2.0.0 installed on them. IP Communicator works perfectly when the laptops are connected to local network. However when they connect via SSL VPN, the "Services Button" doesn't work properly. When they click on it, they just see a bunch of html code on IP Communicator's screen. All other functions of IP Communicator, including phone conversations, work fine over the VPN.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Thu, 02/08/2007 - 15:37

It's trying to a HTTP: path to the CCM Publisher server. If this is blocked for some reason or you have created a DNS name for this, it has to be able to traverse the VPN tunnel through the network.

kendo.igor Thu, 02/08/2007 - 16:32

I can successfully ping and make http connection to publisher and subscriber. Still having the same problem though.

Tommer Catlin Thu, 02/08/2007 - 16:40

Pinging is one thing. HTTP or https is another thing.

Typcially, you only open up certain ports for IPC to work correctly. When you press the "Services" buttons, its actually calling to the webserver on CCM Publisher. Its a site just built for XML for the phone and to view on your IPC.

I would trace out the the ports that are enabled from your IPSEC tunnel to your CCM publisher. Sounds like 80 or 443 or both from the tunnel are not reaching the publisher.

kendo.igor Fri, 02/09/2007 - 10:56

Just found out something strange. If I connect any of the laptops to the local network, open IP Communicator, and click on "Services" button while attached to local network, it starts working. From that point on, the "Services" button on those laptops continue to work properly, even over the SSL VPN. Somehow "Services" button needs to be pushed at least once while connected to the local network in order for it to work.

Actions

This Discussion