No link on Catalyst 2950

Answered Question
Feb 9th, 2007

Hello Everyone!

I've tried to setup a network with one Catalyst 2950 and one Catalyst 2900XL.

The problem is that the link wont go up.

I've tried about 5 ports and none of them worked. I get a link when connecting a computer to these ports.But there is no link when connecting to the C2950. I can connect my computer to both ports but not the switches. I can also connect a Zonet switch to these ports and they work. All ports on both switches are connected to vlan 1 for testing. Note: When booting the C2950 , i get a link. But after the bootup , there is no link. And there is nothing wrong on the post.

I have this problem too.
0 votes
Correct Answer by glen.grant about 9 years 7 months ago

If you get a link with a computer there is nothing wrong with the ports . Have to have a crossover cable for this setup , there is no mdix for these switches . It should work either hardcoded or both sides set as auto . Do a show vlan and make sure vlan 1 shows active on both switches . As you do not have portfast turned on the ports it will take about 50 seconds before the ports go into a forwarding state .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jon Marshall Fri, 02/09/2007 - 08:23

Hi

What type of rj45 cable are you using to connect the two switches. It will need to be a crossover cable and not a straight thru which is what you use to connect your pc to the switch.

HTH

Jon

ewf_cirda Fri, 02/09/2007 - 08:30

I've tried both crossover cables and straight-through cables on a few ports.

Jon Marshall Fri, 02/09/2007 - 08:32

Hi

Okay can you check the speed/duplex settings on both ports. Make sure they are the same. Also make sure that both ports are in the same vlan.

Could you send the configs of both switches and tell us which ports you are trying to connect.

Jon

Jon Marshall Fri, 02/09/2007 - 09:24

Hi

Are you trying to connect the switches with a trunk port or just as an access port ?

Could you set both ports to be 100 full and then try again.

Jon

ewf_cirda Fri, 02/09/2007 - 09:33

I'm trying to make it an access port for now. I've tried to set speed and duplex but it didn't work.

Correct Answer
glen.grant Fri, 02/09/2007 - 17:04

If you get a link with a computer there is nothing wrong with the ports . Have to have a crossover cable for this setup , there is no mdix for these switches . It should work either hardcoded or both sides set as auto . Do a show vlan and make sure vlan 1 shows active on both switches . As you do not have portfast turned on the ports it will take about 50 seconds before the ports go into a forwarding state .

ewf_cirda Sat, 02/10/2007 - 01:29

Thanks!

It looks like the cables i tried didn't work. They were marked as crossover-cables but none of them were. I then found a real crossover cable and got a link and a duplex missmatch and thats now fixed. Thank you!

Jon Marshall Sat, 02/10/2007 - 03:48

Hi

Glad you got it working.

Very quick check for cables. Hold the two ends side by side with the back of the clips facing you. If all the colours are in the same place on both clips it's a straight thru. Otherwise chances are it's a crossover

Jon

Actions

This Discussion