MPLS with subinterfaces

Unanswered Question
Feb 9th, 2007

Is it possible to run the VRF's over subinterfaces.

I want a PE which will be connected to a L2 switch on a dotq trunk and will have two subinterfaces corresponding to 2 customers to forward the traffic out the proper sub interfaces.

The switch is a pure L2 switch and is not possible to run VRF lite on it.

The setup works perfectly when both the customers are terminated on different LAN interface.

Is there any special configuration required to make this work with subinterfaces?

Narayan

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alexander.muhin Fri, 02/09/2007 - 08:49

Hi Narayan,

It's not a problem.

Here is an example (PE1):

!

interface FastEthernet0/0

no ip address

no shutdown

!

interface FastEthernet0/0.1

description VRF EFS

encapsulation dot1Q 2

ip vrf forwarding EFS

ip address 144.12.16.1 255.255.255.0

no ip redirects

no ip proxy-arp

no shutdown

!

interface FastEthernet0/0.2

description VRF VoIP

encapsulation dot1Q 3

ip vrf forwarding VoIP

ip address 172.16.2.1 255.255.255.0

no ip redirects

no ip proxy-arp

no shutdown

!

Regads,

Alexander

royalblues Fri, 02/09/2007 - 10:13

Thanks Alexander,

I had tried this on Dynamips simulation but it failed as soon as i created a 2nd subinterface. Will try it once again

I do not have lab equipments to try this out and hence wanted to confirm before i decide on this

Narayan

Actions

This Discussion