TE config help

Unanswered Question
Feb 11th, 2007

Hi,

We currently have dual links between our core routers (7206VXRs) - Primary being ATM, and secondary being Ethernet - At present, Ethernet is only used if ATM fails(This is achieved via OSPF)....we presently only have mpls enabled on the ATM links.

We are wanting to make more efficient use of the backup ethernet links(As they are expensive)....hoping that TE is the correct(best practice) option.

Our current bandwidth is as follows:

ATM - 8Mb

Ethernet - 4Mb

Our goal is to (hopefully) have a total of 12Mb bandwidth available for use(i.e. Load-share over both the ATM+Ethernet links)......Is FRR necessary in what we are wanting to achieve?

Proposed config for one of the Core routers...

mpls traffic-eng tunnels

no mpls traffic-eng auto-bw timers frequency 0

tag-switching tdp router-id Loopback0

router ospf 100

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

interface FastEthernet2/0

description Point-to-Point Link SYD

bandwidth 4000

ip address xxx.xxx.xxx.197 255.255.255.252

ip ospf message-digest-key 10 md5 blah

### Would this still be required?

ip ospf cost 100

tag-switching ip

tag-switching mtu 1520

service-policy output TRUNK-TO-SYD

mpls traffic-eng tunnels

### Not too sure about this?

ip rsvp bandwidth ? ?

interface ATM1/0.100 point-to-point

description TRUNK LINK TO SYD

bandwidth 8000

ip address xxx.xxx.yyy.2 255.255.255.252

ip ospf message-digest-key 10 md5 blah

tag-switching ip

service-policy output TRUNK-TO-SYD

mpls traffic-eng tunnels

### Not too sure about this?

ip rsvp bandwidth ? ?

interface Tunnel2

description primary tunnel2 ERT01-BNE->ERT01-SYD

ip unnumbered Loopback0

no ip directed-broadcast

tag-switching ip

tunnel destination xxx.xxx.yyy.248

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 7 7

### Not too sure about this?

tunnel mpls traffic-eng bandwidth ?

tunnel mpls traffic-eng path-option 5 dynamic

Apprecaite all assisntance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
romccallum Mon, 02/12/2007 - 04:28

ok mate rsvp bancwidth is the max you will allow reserved (If needed) down an interface.

Tunnel bandwidth is how much bandwidth should your tunnel be looking for.

e.g.

RSVP = 100meg

Tunnel wants 80 meg

This will work

RSVP=10 meg

Tunnel wants 20 meg <-- tunnel will never come up.

HTH

johnelliot Mon, 02/12/2007 - 13:43

Thanks mate - So I would be looking at something like(Three 4Mb tunnels running between the 7200's):

mpls traffic-eng tunnels

tag-switching tdp router-id Loopback0

router ospf 100

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

interface FastEthernet2/0

description Point-to-Point Link SYD

bandwidth 4000

ip address xxx.xxx.xxx.197 255.255.255.252

ip ospf message-digest-key 10 md5 blah

ip ospf cost 100

tag-switching ip

tag-switching mtu 1520

service-policy output TRUNK-TO-SYD

mpls traffic-eng tunnels

ip rsvp bandwidth 4000 4000

interface ATM1/0.100 point-to-point

description TRUNK LINK TO SYD

bandwidth 8000

ip address xxx.xxx.yyy.2 255.255.255.252

ip ospf message-digest-key 10 md5 blah

tag-switching ip

service-policy output TRUNK-TO-SYD

mpls traffic-eng tunnels

ip rsvp bandwidth 8000 8000

interface Tunnel2

description primary tunnel2 ERT01-BNE->ERT01-SYD

ip unnumbered Loopback0

no ip directed-broadcast

tag-switching ip

tunnel destination xxx.xxx.yyy.248

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 4000

tunnel mpls traffic-eng path-option 5 dynamic

interface Tunnel3

description primary tunnel3 ERT01-BNE->ERT01-SYD

ip unnumbered Loopback0

no ip directed-broadcast

tag-switching ip

tunnel destination xxx.xxx.yyy.248

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 4000

tunnel mpls traffic-eng path-option 5 dynamic

interface Tunnel4

description primary tunnel4 ERT01-BNE->ERT01-SYD

ip unnumbered Loopback0

no ip directed-broadcast

tag-switching ip

tunnel destination xxx.xxx.yyy.248

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 4000

tunnel mpls traffic-eng path-option 5 dynamic

mheusinger Mon, 02/12/2007 - 14:37

Hi,

as load sharing over TE tunnels is done by CEF and unequal cost is taken into account, onl two tunnels are needed. So create one 4 Mbps and one 8 Mbps Tunnel (or 800 kbps and 400 kbps with the same result) and route them over the respective links. Do not forget about the return path!

Regards, Martin

johnelliot Mon, 02/12/2007 - 14:47

Hi Martin,

Are you suggesting I do something like:

int tun3

tunnel mpls traffic-eng bandwidth 8000

tunnel mpls traffic-eng path-option 1 explicit name tunnel_3 lockdown

ip explicit-path name tunnel_3 enable

next-address xxx.xxx.xxx.1

mheusinger Mon, 02/12/2007 - 22:53

Yes. you do not need to lockdown the 8 Mbps tunnel, it will only find one path anyhow. Make sure the 4 Mbps tunnel does not have higher hold priority than the setup priority of the bigger tunnel any they sould end up in the prefered links.

CEF will do te load sharing based on reserved bandwidth, i.e. 2:1 though IP routing will see two parallel equal cost pathes. Make sure the tunnel is announced to IP routing (autoroute announce) and has better metric than the physical path (relative metric -1).

Regards, Martin

johnelliot Tue, 02/13/2007 - 13:38

Thanks Martin.

One question - Why do you suggest to use explicit, rather than dynamic path selection?

And under each tunnel to have a better metric, I would have:

tunnel mpls traffic-eng autoroute metric relative -1

Actions

This Discussion