Multicast/OSPF and gre tunnel

Unanswered Question
Feb 12th, 2007

Hi all.

I've got a scenario where there are 3 routers in a hub and spoke frame relay cloud.

R1 is the hub and R5 and R6 the spokes.

OSPF in the routing protocol.

Multicast routing is enabled,

R1 is the RP where R6 is the Mapping agent... so to make auto-rp working I'm creating a GRE tunnel from R5 to R6.

I'm posting in attachment the 3 router configs:

Now, can anybody explain me why am I not getting a route for 6.6.6.6 on R5 nor for 5.5.5.5 on R6? They should go out Serial 1/2 to R1 and R1 should advertise to the opposite spoke.

R5:

1.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

O 1.1.6.6/32 [110/6] via 50.0.0.6, 00:27:51, Tunnel0

O 1.1.1.1/32 [110/65] via 192.168.2.1, 00:27:51, Serial1/2

C 1.1.5.0/24 is directly connected, Loopback0

50.0.0.0/24 is subnetted, 1 subnets

C 50.0.0.0 is directly connected, Tunnel0

5.0.0.0/24 is subnetted, 1 subnets

C 5.5.5.0 is directly connected, Loopback1

172.16.0.0/24 is subnetted, 1 subnets

O 172.16.1.0 [110/74] via 192.168.2.1, 00:27:51, Serial1/2

10.0.0.0/24 is subnetted, 1 subnets

O 10.10.10.0 [110/65] via 192.168.2.1, 00:27:51, Serial1/2

192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.2.0/24 is directly connected, Serial1/2

O 192.168.2.1/32 [110/64] via 192.168.2.1, 00:27:52, Serial1/2

R6:

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

O 1.1.5.5/32 [110/6] via 50.0.0.5, 00:28:31, Tunnel0

O 1.1.1.1/32 [110/65] via 192.168.2.1, 00:28:31, Serial1/2

C 1.1.6.0/24 is directly connected, Loopback0

50.0.0.0/24 is subnetted, 1 subnets

C 50.0.0.0 is directly connected, Tunnel0

6.0.0.0/24 is subnetted, 1 subnets

C 6.6.6.0 is directly connected, Loopback1

172.16.0.0/24 is subnetted, 1 subnets

O 172.16.1.0 [110/74] via 192.168.2.1, 00:28:32, Serial1/2

10.0.0.0/24 is subnetted, 1 subnets

O 10.10.10.0 [110/65] via 192.168.2.1, 00:28:32, Serial1/2

192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.2.0/24 is directly connected, Serial1/2

O 192.168.2.1/32 [110/64] via 192.168.2.1, 00:28:34, Serial1/2

Last question: Is there a debug command in OSPF showing the routes advertised/received by the router?

I can't find anything soing so...

Thanks to read.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion