QOS Problem

Answered Question
Feb 12th, 2007

Hi all,

I have a small MPLS with limited bandwidth. I am trying to create a QOS policy to guarentee 512kb/sec for my voice traffic, 64kb/sec for ping and telnet (to always make sure I can telnet and test connectivity to my routers), 50% of the remaining to my business system, 25% of the remaining to email, 24% to everything else, and only 1% for file-sharing programs like kazaa.

I have tried the following QOS policy on my routers. It looks good to me, but as soon as I put it on the interface ping responses jump from ~40ms to sometimes as much as 1000ms. Can anyone see what I am doing wrong?

ip access-list ext ACLimportant

remark ACL to give low bandwidth important traffic higher priority

permit icmp any any

permit tcp any any eq telnet

ip access-list ext ACLqad

permit ip any host 10.1.1.7

permit ip host 10.1.1.7 any

ip access-list ext ACLemail

remark ACL To and From Email servers for QOS

permit ip any host 10.1.1.8

permit ip host 10.1.1.8 any

permit ip any host 10.2.1.2

permit ip host 10.2.1.2 any

permit ip any host 10.2.1.18

permit ip host 10.2.1.18 any

class-map match-any qad

match access-group name ACLqad

class-map match-any email

match access-group name ACLemail

class-map match-any voice

match dscp ef

class-map match-any badtraffic

match protocol gnutella

match protocol kazaa2

match protocol napster

class-map match-any important

match access-group name ACLimportant

policy-map pmap_mpls

class voice

priority 512

class important

set dscp af21

priority 64

class qad

set dscp af21

bandwidth remaining percent 50

class email

set dscp af11

bandwidth remaining percent 25

class badtraffic

set dscp 0

bandwidth remaining percent 1

random-detect dscp-based

class class-default

set dscp 0

bandwidth remaining percent 24

random-detect dscp-based

interface s0/0/0

service-policy output pmap_mpls

Thanks!

Eric

I have this problem too.
0 votes
Correct Answer by mheusinger about 9 years 7 months ago

Hi,

I would not recommend the "priority" queue but to use "bandwidth" instead. This should give more predictable behaviour as PQ comes with a policer, which might adversely affect your traffic.

So try

policy-map pmap_mpls

class voice

priority 512

class important

set dscp af21

bandwidth percent remaining 10

Also make sure the marking AF21 is used properly on all other components in your network. Delays could arise somewhere else in the network. In addition be aware, that this policy will handle TRANSIENT traffic, i.e. NOT generated by the router itself.

To prioritize local traffic use a local policy "ip local policy route-map". With the route-map describe the traffic through an ACL and set IP precedence. In your QoS policy use the marking to sort the traffic into the relevant class.

Regards, Martin

[Edit] The bandwidth percent should not exceed 100% in total AND - most important - refers to the interface bandwidth. Serials are defaulting to T1 (!). Make sure you configure the bandwidth correctly on your interface:

interface s0/0/0

bandwidth 1000 !replace with real bandwith of your access line.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
mheusinger Mon, 02/12/2007 - 09:49

Hi,

I would not recommend the "priority" queue but to use "bandwidth" instead. This should give more predictable behaviour as PQ comes with a policer, which might adversely affect your traffic.

So try

policy-map pmap_mpls

class voice

priority 512

class important

set dscp af21

bandwidth percent remaining 10

Also make sure the marking AF21 is used properly on all other components in your network. Delays could arise somewhere else in the network. In addition be aware, that this policy will handle TRANSIENT traffic, i.e. NOT generated by the router itself.

To prioritize local traffic use a local policy "ip local policy route-map". With the route-map describe the traffic through an ACL and set IP precedence. In your QoS policy use the marking to sort the traffic into the relevant class.

Regards, Martin

[Edit] The bandwidth percent should not exceed 100% in total AND - most important - refers to the interface bandwidth. Serials are defaulting to T1 (!). Make sure you configure the bandwidth correctly on your interface:

interface s0/0/0

bandwidth 1000 !replace with real bandwith of your access line.

emphillips00 Mon, 02/12/2007 - 16:57

Hi Martin,

Thanks a bunch for the help. I put the "important" traffic in the same class as my business application's class, so it gets a big percentage and not a priority queue, and that seems to be working much better.

I don't quite understand it though... There is not much ICMP or telnet traffic on my network. My understanding is the priority queue is a minimum AND maximum (ie... if 65kb/sec of ICMP traffic tried to flow, it would drop 1kb/sec). But I have never used two priority queues, so I don't know...

And thank you for reminding me about the bandwidth and transient issue... I did happen to remember those from my CCNP studies, but it is always good to keep that in mind.

We shall see how the new queueing works!

Thanks!

Eric

Actions

This Discussion