OSPF configuration question

Unanswered Question
Feb 12th, 2007

Hi Everyone,

I have set up a CCNP lab at work and am getting started with my OSPF setup and I have a question.

I wired my lab as shown in the attached jpeg and have configured the OSPF settings as follows.

ROUTER 1:

router ospf 1

network 172.12.123.0 0.0.0.255 area 0

network 1.1.1.1 0.0.0.0 area 1

network 10.10.10.0 0.0.0.255 area 1

ROUTER 2:

router ospf 2

network 172.12.123.0 0.0.0.255 area 0

network 2.2.2.2 0.0.0.0 area 2

network 20.20.20.0 0.0.0.255 area 2

ROUTER 3:

router ospf 3

network 172.12.123.0 0.0.0.255 area 0

network 3.3.3.3 0.0.0.0 area 3

network 30.30.30.0 0.0.0.255 area 3

When I do a show ip ospf neighbors, I see Router 2 as the DR, Router 3 as the BDR, and Router 1 as the DROTHER

I don't understand why this is happening. I am expecting to see that Router 3 is the DR (since it has the highest loopback IP address) and router 2 to be the BDR.

I feel like a dunce asking this since my setup seems simple enough.

Thanks for the help.

Pete

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Mon, 02/12/2007 - 11:34

You are correct, the higest router id should serve as tie-breaker if the priorities are all the same. However, once the DR election is over if another router comes online with a higher priority/ID it wouldn't become the DR until the already elected DR/BDR fails. I assume you must have configured/powered on R3 after R1 & R2. Clear the ip ospf process on all 3 devices quickly and you should see the DR election resulting the expected outcome.

HTH

Sundar

priedman1 Mon, 02/12/2007 - 12:05

Hi Sundar,

Thanks for the explanation. I did clear the OSPF processes on the routers but perhaps my timing was not good enough to get things as I expected.

Pete

Richard Burts Mon, 02/12/2007 - 11:36

Pete

This is a fairly common issue to run into as you are learning OSPF. The explanations of OSPF election of DR/BDR focus on the relationship of loopback address/physical address as the RID and election based on the RID. The aspect that they typically do not discuss is the issue of timing. When the first router boots up it looks for neighbors and if it finds neighbors then there is an election as commonly described. But if there is no neighbor present, the router waits a short time to see if one will appear and if not then the router conducts the election for DR and that router is the only candidate.

So based on your description I believe that router 2 booted first and was the only router present for a little time, and conducted the election. Then router 3 booted up and was elected as BDR. If you want to test this, I suggest that you power down the routers, and then power up the routers as nearly simultaneously as you can and see what happens.

HTH

Rick

priedman1 Mon, 02/12/2007 - 12:06

Hi Rick,

THanks for the help. Your advice has cleared a number of questions for me.

Much appreciated.

Pete

Edison Ortiz Mon, 02/12/2007 - 13:34

If you want to ensure the DR election on a particular router, just change the priority to 0 in the remaining routers' interface.

Keep in mind, if the intended DR router fails, your OSPF topology will be broken until a DR is present, therefore I don't recommend this option in production environment.

priedman1 Mon, 02/12/2007 - 13:43

Hi Edison.

For a production environment, is it customary for a priority to be set for the preferred DR router and a lower priority to be set for the preferred BDR and the other routers set with a priority of zero?

Thanks again

Pete

Richard Burts Mon, 02/12/2007 - 14:00

Pete

In my experience most people do not bother with setting priority, especially in LAN environments. There are a few situations, especially multipoint Frame Relay, where it may be imoprtant to set priority, but I believe that mostly people use the default priority.

If you have a situation where you think it does matter, then you should plan carefully what router(s) get the highest priority, what router(s) get other priority, and what router(s) get zero priority. Also if you have a situation where you have assigned priority to manage which router is DR, then you should have a plan about monitoring to verify if that router continues to be DR. Because there could be a situation where that router (or that interface) went out of service temporarily, and then the router is no longer the DR.

If you are trying to learn about the protocol (and especially if you are studying for some certification) it is important to understand how features like this work. But many of these features are not widely used in production networks. They are used where they are needed.

HTH

Rick

priedman1 Mon, 02/12/2007 - 14:04

Hi Rick,

Thanks again. I've only worked in EIGRP shops so I'm trying to shake off the rust from my CCNP classes from a while ago and sharpen up for the exams.

Your insight is greatly appreciated. Hopefully I don't pester the forum too much with questions. ;-)

Thanks again

Pete

Actions

This Discussion