Cisco 851 router static IP setup????

Unanswered Question
Feb 12th, 2007

My 851 router will work for DHCP setup, but won't work if I set it up to Static IP. Besides, I can't find anywhere to input the Gateway information. Any solution? Many thanks!!!!!!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
spremkumar Mon, 02/12/2007 - 20:20

Hi

Are you configuring DHCP (to negotiate address) on the wan interface or in the lan interface ?

regds

biologixlee Mon, 02/12/2007 - 21:41

I was configuring on wan interface. I just figured out that the Gateway will need to be configured in "routing" section. Now I get the wan working with a static IP, but new problems showed up--I configured some NAT port forwarding but none of them worked for me. I have a web server behind the router, but now with the NAT setting all connection through port 80 will go to router remote login. I'm not a professional and I'm even more confused now.

Thanks.

benson.olowomuke Tue, 02/13/2007 - 00:18

It works with DHCP because the router is doing auto negotiating i.e on the WAN interface its configured as "ip address dhcp".

To input the Gateway address, go into configurature mode and input the gateway address like this..

Router (config)#ip route 0.0.0.0 0.0.0.0 x.x.x.x

(X indicating the gateway IP add.)

use your ctrl + Z to go back to your router prompt..After doing that, make sure you can ping the gateway address from there. First attempt might come back 70 or 80%, but keep trying and it would be 100%.

Save your config and you are all set.

Note: Check your config. and make sure you have no ACL blocking IP traffic from that IP block, no ACL blocking ICMP traffic, and make sure all IP addresses are correct.

biologixlee Tue, 02/13/2007 - 06:51

Thank you guys!

Now the router is working with a static IP. But does anybody know how to solve this?

===============================================

I configured some NAT port forwarding but none of them worked for me. I have a web server behind the router, but now with the NAT setting all connection through port 80 will go to router remote login.

==========================================

PS: I'm not an IT guy, the SDM is the only way I can handle to config the router.

Thanks

benson.olowomuke Sun, 10/26/2008 - 10:53

sorry for the late reply...

are you trying to use rdp(remote desktop protocol)?..if so, the port number is 3389, you will need a static ip for the host you are trying to rlogin into..

A copy of your config will help solve this issue.

Actions

This Discussion