WS-C2950-24 EtherChannels setup for Intel(R) PRO/1000 MT Dual Port NICs

Unanswered Question
Feb 13th, 2007

I have a WS-C2950-24. I want to setup an EtherChannel of 2 ports. Those ports are connected to 2 Intel(R) PRO/1000 MT Dual Port of a Microsoft Windows Server 2003 Standard Edititon SP1 (OEM). The hardware is an Xtore WSS NAS (XN-104R-T2SP) (see http://www.xtore.com/product_Detail.asp?id_cat=1&id=13). How do I setup the Intel NICs with driver version8.5.14.0 for Express Teaming to comply with the Cisco EtherChannels.

many thanks

Guy Schepens

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cisconoobie Tue, 02/13/2007 - 08:03

Example

Your server is on Vlan 10

Server:

Use the Intel proset to create a LACP Team with VLAN 10 Tagging.

Both NICs are combined and use a single logical NIC that accepts traffic on Vlan 10.

Give it a Vlan 10 IP, mask,gw,etc

Switch:

Say these switchports are G10 and G20

Assuming Vlan 1 is native vlan

conf t

int g10

shutdown

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk vlan allowed 1,10

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

int g20

shutdown

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk vlan allowed 1,10

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

int g10

no shutdown

int g20

no shutdown

If your NIC Team on server is setup properly then you will have a LACP etherchannel setup.

lonegunman Tue, 02/13/2007 - 08:36

Thanks for the reply.

I have to admid I'm new in these things and telnet sessions are replaced by the beautifull Cisco Network Assistant app. Running via Parallell's Desktop Windows XP Pro SP2 on MacBook Pro 10.4.8

The struggle I have in with the Intel NICs is that only in the Advanced Properties of the NIC's I can get to Teaming. That's why the driver version as mentioned is the only one that is offering this. In literature on this I read about the Intel proset but have failed to visualise it in any interface on Windows. Perhaps the hardware I'm using (Xtore NAS) is prohibiting the use of this??

So in the Advanced Props I have:

Adaptive inter-Frame Spacing, Enable PME, Express Teaming, Flow Control, Interrupt Moderation Rate, Jumbo Frames, Link Speed & Duplex, Locally Administered Address, Log Link State Event, Offload Receive IP Checksum, Offload Receive TCP Checksum, Offload TCP Segmentation, Offload Transmit IP Checksum, Offload Transmit TCP Checksum, QoS Packet Tagging, Receive Descriptors, Transmit Descriptors, Wait for Link, Wake On Link Settings and Wake On Settings.

Can you indicate how these should be set to comply with LACP Team with VLAN 10 Tagging?

Also much appreciated is the translation of your telnet commands into CNA. eg. I have created an EtherChannel on port Fa0/18 and Fa0/19, Mode = LACP, Priority is 32768; Load Balance is set to Source MAC address... Then I'm lost.

Any input is very much appreciated.

Thanks - Guy Schepens

cisconoobie Tue, 02/13/2007 - 14:53

Ouch.. I havent done that with CNA yet. DOing that in telnet, its easy. Do this.

>enable

#configure terminal

hostname(config)#interface G1/0/10

hostname(config-if)#shutdown

hostname(config-if)#switchport trunk encapsulation dot1q

hostname(config-if)#switchport mode trunk

hostname(config-if)#switchport trunk vlan allowed 1,10

hostname(config-if)#switchport nonegotiate

hostname(config-if)#channel-protocol lacp

hostname(config-if)#channel-group 1 mode active

hostname(config-if)#exit

hostname(config)#interface g1/0/20

hostname(config-if)#shutdown

hostname(config-if)#switchport trunk encapsulation dot1q

hostname(config-if)#switchport mode trunk

hostname(config-if)#switchport trunk vlan allowed 1,10

hostname(config-if)#switchport nonegotiate

hostname(config-if)#channel-protocol lacp

hostname(config-if)#channel-group 1 mode active

hostname(config-if)#exit

hostname(config)# interface g1/0/10

hostname(config-if)#no shutdown

hostname(config-if)#exit

hostname(config)# interface g1/0/20

hostname(config-if)#no shutdown

Just follow these on the command prompt, "hostname" will be whatever your switches name is and make sure the syntax for the Interface XXXXXXX is correct. Make sure you have the proper vlan that the server will be in.

You need to download the IntelProset complate driver package. All you have installed is the driver, there is more to it than that. When you download it, extract it and run the exe to install it. Then there is a wizard for creating teaming. Simple.

lonegunman Thu, 02/15/2007 - 06:20

Finally spotted the Intel Proset in Device Manager. Was just taking some time to publish the options window on screen.

Will do the telnet session later today and keep you posted.

Thanks for the help so far!

Guy Schepens

lonegunman Thu, 02/15/2007 - 06:35

Just preparing for tonite:

In your example you put server on Vlan 10 assuming Vlan 1 is native Vlan...

We only have Vlan 1 as default lan since we don't use IP subsets.

So if server is also on Vlan 1 should the telnet command lines state instead of 1,10 -> 1,1 or should that line be skipped in my scenario?

Many thanks - Guy

Actions

This Discussion