EIGRP

Answered Question

Hi!

i have a couple of questions!

1)if we have 4 link, the first 3 is gig and the 4 one running on the gig interface, but the actual speed is 300M?

2)can i run Multilink bundle on this 4 Links(1 of the 4 in different speed 300M But running on the gig interface)?

3)how can i do load balence & redundancy for this 4 link?

4)do i need to do l3 etherchannel(L3) for the first 3 link,and the 4 link(300M) for backup?

5)i want to use EIGRP AS ROUTING PROTOCOL,How EIGRP Will work for this situation?

plz waiting ur kind reply...

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 9 years 7 months ago

Hi

From Cisco doc:-

=============================================

EIGRP puts up to four routes of equal cost in the routing table, which the router then load-balances. The type of load balancing (per packet or per destination) depends on the type of switching being done in the router. EIGRP, however, can also load-balance over unequal cost links.

Note: Using max-paths, you can configure EIGRP to use up to six routes of equal cost.

Let us say there are four paths to a given destination, and the metrics for these paths are:

path 1: 1100

path 2: 1100

path 3: 2000

path 4: 4000

The router, by default, places traffic on both path 1 and 2. Using EIGRP, you can use the variance command to instruct the router to also place traffic on paths 3 and 4. The variance is a multiplier: traffic will be placed on any link that has a metric less than the best path multiplied by the variance. To load balance over paths 1, 2, and 3, use variance 2, because 1100 x 2 = 2200, which is greater than the metric through path 3. Similarly, to also add path 4, issue variance 4 under the router eigrp command. Refer to How Does Unequal Cost Path Load Balancing (Variance) Work in IGRP and EIGRP? for more information.

=============================================

So in your case you have to look at metric for the L3 etherchannel and the metric for the wireless link and then work out how many times you have multiply the metric for your L3 etherchannel to get to the metric for your wireless link.

Note that the wireless link must be a feasible successor to be used in unequal cost load-balancing so refer back to earlier posts for info on how to do this.

HTH

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (14 ratings)
Loading.
royalblues Wed, 02/14/2007 - 04:57

Friend,

There are 2 ways to use EIGRP over different bandwidth links if you want to loadbalance.

1. use the variance parameter and load balance

2. configure multilink on the 3 links and run eigrp on the multilink interface.

Below excerpt from a TAC response for loadbalancing on different speed links in a multilink

Multilink gives data to the links on demand.

Several small frames may land on one link to balance a large frame on another link. A fast link draws more data than a slow link. Over time, the amount of data sent on each link is proportional to its bandwidth.

MLPPP do make a point of spreading frames across all links as much as possible, and keeping all the links equally utilized. Hence if each link takes about the same amount of time to transmit the frames given to it, the results will approximate round-robin distribution.

If you want to have redundancy, then just make sure you run eigrp on the interface.

The traffic will be diverted to this link if all other linsk fail

HTH, rate if it does

Narayan

royalblues Wed, 02/14/2007 - 09:17

Sorry friend,

I didn't realise that you are using ethernet interfaces.

In this case you need to go with etherchannel as multilink is not supported on ethernet interfaces.

For etherchannel to work though, the interfaces parameters should match and the same should be reflected in the configuration

HTH, rate if it does

Narayan

sundar.palaniappan Wed, 02/14/2007 - 09:28

Configure a port channel (layer 3 etherchannel) for the 3 links and the configure 300 mbps gig interface as a routed port. Thus, you would have two layer 3 interfaces. Configure both interfaces to run EIGRP. EIGRP, by default, does equal cost load balancing on up to 4 paths. Configure the bandwidth and delay to be the same on the port channel interface and the 300 mbps gig interface because EIGRP uses this for metric calculation. As far as Etherchannel/portchannel configuration is concerned you need to configure them the same way on both ends of the link.

This would provide load balancing and redundancy in case of failure of one of the links. Instead, if you only configure all 4 links, 3 as etherchannel & gig as layer 2 int, as layer 2 connections then STP would block one of the links and the other one would forward and this would provide redundancy but wouldn't load balance the traffic.

HTH

Sundar

royalblues Wed, 02/14/2007 - 09:35

In case you want the 4th link to be purely standby, then configure etherchannel between the 3 links and run EIGRP over them.

Configure another eigrp neighbor relationship between your devices over the 4th link(300M). Fine tune the bandwidth & delay parameters on both sides of this link till you see it as a feasible successor to the etherchannel link.

HTH, rate if it does

Narayan

sundar.palaniappan Wed, 02/14/2007 - 09:45

Varaince command is needed only if the metric via the L3 links are unequal. Assuming you have configured the same bandwidth/delay on both l3 interfaces the EIGRP metric should be the same and there would be no need for 'variance' command. It depends on how you have it configured.

HTH

Sundar

sundar.palaniappan Wed, 02/14/2007 - 10:11

Post the output of 'show ip eigrp nei' and 'show ip eigrp top' and let us know which link is what.

royalblues Wed, 02/14/2007 - 10:17

As i said earlier configure 2 neighbor relationhip between the devices, one along the etherchannel and one along the wireless link.

For faster convergence, fine tune the parameters on the wireless links so that it becomes a feasible successor to the etherchannel.

This will ensure the link always acts as standby and will pass traffic only when the entire etherchannel fails.

Narayan

hi the config for my Setup is here:

SW1-SUP720

**********

interface GigabitEthernet2/1

description "L3 Point-To-Point Leaser-link to SW2-SUP2""

no ip address

channel-group 14 mode on

!

interface GigabitEthernet2/2

description "L3 Point-To-Point Leaser-link to SW2-SUP2"

no ip address

channel-group 14 mode on

!

interface GigabitEthernet2/3

description "L3 Point-To-Point Leaser-link to SW2-SUP2""

no ip address

channel-group 14 mode on

!

interface Port-channel14

ip address 192.168.1.1 255.255.255.252

!

interface GigabitEthernet3/1

description "L3 wirless link to SW2-SUP2"

ip address 192.168.1.4 255.255.255.252

!

router eigrp 1

network 192.168.1.0 0.0.0.3

no auto-summary

.............................................................

SW2-SUP2

********

interface GigabitEthernet2/1

description "L3 Point-To-Point Leaser-link to SW1-SUP720""

no ip address

channel-group 14 mode on

!

interface GigabitEthernet2/2

description "L3 Point-To-Point Leaser-link to SW1-SUP720

no ip address

channel-group 14 mode on

!

interface GigabitEthernet2/3

description "L3 Point-To-Point Leaser-link to SW1-SUP720""

no ip address

channel-group 14 mode on

!

interface Port-channel14

ip address 192.168.1.2 255.255.255.252

!

interface GigabitEthernet3/1

description "L3 wirless link to SW1-SUP720"

ip address 192.168.1.5 255.255.255.252

!

router eigrp 1

network 192.168.1.0 0.0.0.3

no auto-summary

10xs

royalblues Wed, 02/14/2007 - 10:26

use the bandwidth & delay command under the interface conencting to the wireless link.

you can check the FD of the etherchannel route through sh ip eigrp topology

if you can post the output of the above command it would be easier to suggest

Narayan

royalblues Wed, 02/14/2007 - 10:35

if it works as desired then you do not need to configure the delay. These are the 2 parameters generally used to influence EIGRP metric.

It is not mandatory to use both of them :-)

BTW it is configured under the interface

int g 3/1

delay 2000

note: - delay is measured in tens of microseconds

Narayan

sundar.palaniappan Wed, 02/14/2007 - 11:01

IP addressing is incorrect on wireless link and you don't have EIGRP enabled on that interface. Configure the following;

interface GigabitEthernet3/1

description "L3 wirless link to SW2-SUP2"

ip address 192.168.1.5 255.255.255.252

router eigrp 1

network 192.168.1.5 0.0.0.0

SW2-SUP2:

interface GigabitEthernet3/1

description "L3 wirless link to SW1-SUP720"

ip address 192.168.1.6 255.255.255.252

!

router eigrp 1

network 192.168.1.6 0.0.0.0

HTH

Sundar

royalblues Wed, 02/14/2007 - 11:11

Ali,

Just mention the bandwidth under the wireless link as 300000. This will ensure that it does not become the successor.

Once this is done, do a sh ip eigrp topology and see whether the wireless route comes up as FS in the table. Then you can start tuning these values till it appears in the topology as a FS.

And as Sundar has posted please ensure EIGRP is running on this interface.

Note: - Even if the link is not a FS, eigrp will route the traffic over this link. It only does a local computation (by sending queries to the neighbor).

This process does not take place if the route is installed as a FS.

Another way is to add a floating static route with an AD greater than 90 using the wireless link. This route will be installed once the EIGRP route fails.

HTH

Narayan

Jon Marshall Wed, 02/14/2007 - 13:19

Hi

Eigrp will not send traffic over the wireless link until the L3 etherchannel goes down. When the layer 3 etherchannel goes down the route will be removed from the routing table.

EIGRP will then use the wireless link as an alternative route.

If you wanted to send traffic over both links you would need to use the variance command.

Jon

Correct Answer
Jon Marshall Thu, 02/15/2007 - 01:40

Hi

From Cisco doc:-

=============================================

EIGRP puts up to four routes of equal cost in the routing table, which the router then load-balances. The type of load balancing (per packet or per destination) depends on the type of switching being done in the router. EIGRP, however, can also load-balance over unequal cost links.

Note: Using max-paths, you can configure EIGRP to use up to six routes of equal cost.

Let us say there are four paths to a given destination, and the metrics for these paths are:

path 1: 1100

path 2: 1100

path 3: 2000

path 4: 4000

The router, by default, places traffic on both path 1 and 2. Using EIGRP, you can use the variance command to instruct the router to also place traffic on paths 3 and 4. The variance is a multiplier: traffic will be placed on any link that has a metric less than the best path multiplied by the variance. To load balance over paths 1, 2, and 3, use variance 2, because 1100 x 2 = 2200, which is greater than the metric through path 3. Similarly, to also add path 4, issue variance 4 under the router eigrp command. Refer to How Does Unequal Cost Path Load Balancing (Variance) Work in IGRP and EIGRP? for more information.

=============================================

So in your case you have to look at metric for the L3 etherchannel and the metric for the wireless link and then work out how many times you have multiply the metric for your L3 etherchannel to get to the metric for your wireless link.

Note that the wireless link must be a feasible successor to be used in unequal cost load-balancing so refer back to earlier posts for info on how to do this.

HTH

Jon

devang_etcom Thu, 02/15/2007 - 15:01

Ali,

Multilink PPP is only for the Point to Point link...

if you have ethernet connectivity then you have to go for Ether channel or some thing like Routing protocol equal path or unequal path or you can use the Multiple static routes with the same AD.

if you have VLAN and Different Subnet design in your network then you can have HSRP or GLBP loadbalancing stuff...

regards

Devang

Actions

This Discussion