ISDN cannot stop automatically once primary link down

Unanswered Question
Feb 14th, 2007

I have 2 2811 routers connected with ISDN for backup propose, they can be triggered automatically once the primary link goes down, but cannot be shut down automatically once the primary link resumes. Here is the configuration:

R1:

interface BRI0/0/0

no ip address

encapsulation ppp

no logging event link-status

dialer pool-member 1

isdn switch-type basic-net3

ppp multilink load-threshold 1 outbound

!

interface Dialer0

ip address 172.16.0.1 255.255.255.252

encapsulation ppp

no logging event link-status

dialer pool 1

dialer remote-name r2

dialer idle-timeout 5

dialer string xxxxxxx

dialer-group 1

ppp authentication chap

ppp multilink

ppp multilink load-threshold 1 either

ip route 0.0.0.0 0.0.0.0 Dialer0 200

ip route 10.X.X.0 255.255.255.0 10.X.X.2

router bgp 2

neighbor 172.16.0.2 remote-as 3

access-list 110 deny tcp any any eq bgp

access-list 110 permit ip any any

dialer-list 1 protocol ip list 110

R2:

interface BRI0/0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink load-threshold 1 outbound

!

interface Dialer0

ip address 172.16.0.2 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name r1

dialer idle-timeout 300

dialer string xxxxxxxx

dialer-group 1

ppp authentication chap

ppp multilink

ppp multilink load-threshold 1 either

!

router bgp 3

neighbor 172.16.0.1 remote-as 2

neighbor 172.16.0.1 default-originate

no auto-summary

access-list 110 deny tcp any any eq bgp

access-list 110 permit ip any any

dialer-list 1 protocol ip list 110

From the config, I found both end all can initial call to other end, is it because of this? or because BGP? and how to solve?

thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
pradeepde Tue, 02/20/2007 - 09:05

It may be because of a bug affecting IOS ver 12.0(9) and below. If your IOS ver is 12.0(9) or below please upgrade to 12.0(10) or above. Else in primary interface config please check if backup dealy x x is configured or not. If not please try to configure it with some values in place of x. Else try to change the admin distances for the two different routes. This way only one routes stays in the routing table. You may get help fro this troubleshooting document

http://www.cisco.com/warp/customer/129/isdn_20602.html

purohit_810 Tue, 02/20/2007 - 09:43

Remove Dialer string from one end. So, one one router will have dialer string.... it will only able to dial the number.

Ex: Remove dialer string from r2.

R1 only will able to dial.

Regards,

Dharmesh Purohit

Actions

This Discussion