3750 Bond to Ports?

Answered Question
Feb 14th, 2007

I would like to bond/team 2 ports on my 3750. This is what I current have:

interface Gigabitethernet4/0/21

description "Team Member 1"

Switchport mode access

no ip address

no mdix auto

channel-group 9 mode active

spanning-tree portfast

interface Gigabitethernet4/0/22

description "Team Member 2"

Switchport mode access

no ip address

no mdix auto

channel-group 9 mode active

spanning-tree portfast

Not working tho... any help appreciated. Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
bleucube Wed, 02/14/2007 - 11:33

Actually - I have two gig network cards in my backup server that are teamed - and looking to get two ports on the same switch teamed. Just need more bandwidth for my backup agents to use.

Etherchannel does this correct?

cisconoobie Wed, 02/14/2007 - 12:05

int g4/0/21

switchport trunk encap dot1q

switchport trunk allowed vlan xx

switchport mode trunk

Channel-protocol lacp

channel-group 9 mode active

no spanning-tree portfast

int g4/0/22

switchport trunk encap dot1q

switchport trunk allowed vlan xx

switchport mode trunk

Channel-protocol lacp

channel-group 9 mode active

no spanning-tree portfast

Vlan xx is the vlan that your server is in.

bleucube Wed, 02/14/2007 - 12:11

Will give it a whirl. The main switch in on the same network as the server, so don't need a Vlan.

Curious about the addition of:

Switchport trunk encap dot1q

and turning off spanning-tree portfast

Are these recommend settings?

Those are trunk settings, for trunking vlans across switches/routers.

Not sure if the server NIC teaming process is going to work like you need.

I as understand teaming, 1 virtual IP address = 1 virtual MAc address, across 2 physical NIC connections.

AFAIK this is not a throughput enhancement. You may want to read up on the Server NIC teaming and see how they recommend setting it up.

Etherchannel is a L2 switch to L2 switch function.

bleucube Wed, 02/14/2007 - 12:56

Makes more sense to me. Ah. Yep this is just two network ports coming out out of my backup server going into 1 switch.

Doesn't sound like I can do it through etherchannel then. Thanks!

bleucube Wed, 02/14/2007 - 12:52

Added the config and could not ping the server. Changed switchport mode trunk back to switchport mode access and could ping but port still show as 1 gig.

cisconoobie Wed, 02/14/2007 - 13:21

channel-group 9 mode active

this automatically creates a port channel group 9 for LACP

bleucube Thu, 02/15/2007 - 05:10

no good - even tho mode on is an option in the list, it does not accept it. Do I need to create the channel first?

bleucube Thu, 02/15/2007 - 11:17

Answer was:

Anyhow follow this config as it is and it should solve the issue.

Sw(config) # interface Port-channel9

Sw(config-if)#no description Brain5 Team

Sw(config-if)#no switchport trunk encapsulation dot1q

Sw(config-if)#no switchport mode access

Sw(config)# no interface Port-channel9

Sw(config)#default interface range gi 4/0/21 -22

===========================================

SW(config)#interface range gigabitethernet 4/0/21-22

SW(config-if-range)#switchport mode access

SW(config-if-range)#channel-group 9 mode on

========================================

sw(config)#int port-channel 9

sw (config-if)#no ip address

sw(config-if)#speed full

sw(config-if)#duplex full

end

============================================

cisconoobie Fri, 02/23/2007 - 10:54

I try doing that on a cross-stack on 3750Gs and it does not allow me to use "switchport mode access". I have to use a trunk and it works good for LACP

dahuja Fri, 02/23/2007 - 10:58

no issues with the configuration

check with the teamed adaptors , does your nics support LACP ?

robertg1234 Fri, 02/23/2007 - 18:31

Most host/server nicteaming does not support LACP (or any other etherchannel linking protocol) except for a very few servers (the Dell 1655 comes to mind -- except it's really a Dell managed switch built into the multi-blade server). Most ppl will refer to nicteaming as a HSRP-like backup/failover setup. The NIC mfgr utility will usually show the nicteaming capabilities. This is Windows, of course.

Linux has no such problems :)

Anyway, turning off any aggregation protocol will usually work.

Actions

This Discussion