Link from 2 different ISPs

Unanswered Question

Kindly,have a look to the attached diagram!

i have 2 wireless connection from 2 different ISPs(ISPA;ISPB)ISP A Terminate link at R1;ISPB Treminate link at R2;i want to achieve the following setup:if the first Link(ISPA)fail the second link (ISPB) TAKE OVER.R1 ITS PRIMARY;R2 ITS SECONDERY;also i want to take into my consideration the LOAD Balence and the redandancy.

How can i achieve like this setup?

10xs for ur reply

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (9 ratings)
Loading.
spremkumar Thu, 02/15/2007 - 01:39

Hi Sayed

With the kinda topology you have in placei would suggest to lookout for redundancy in place instead of load balancing.

If you are not having a pool of ips on your own you can have HSRP in combination with NAT which can serve the purpose of both redundancy and access to internet.

Do refer the below link for configuring up the same..

http://www.cisco.com/en/US/partner/products/ps6350/products_configuration_guide_chapter09186a008044edaa.html

regds

devang_etcom Fri, 02/16/2007 - 08:15

ali,

you have two things in redundancy... one is statful and other is statless...

stateful failover is to continue active flows without interruption if the master fails over to the backup.

it means here you can have your session flow is continue even though your active will goes down...

that will be more clear by the following links:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hiap_c/ch20/haiphsrp.htm

http://www.cisco.com/univercd/cc/td/doc/product/webscale/css/css_750/redundgd/redndncy.htm

so its all depend your need...

regards

Devang

devang_etcom Fri, 02/16/2007 - 08:36

then you can go for normal HSRP with the NAT so it will reduce the complexity with your configuration...

static nat with HSRP

devang_etcom Fri, 02/16/2007 - 09:13

Active Router Configuration

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 105 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.n

standby 10 track Fa 0/1

!

!

ip nat inside source static/pool -----redundancy HSRP1

ip classless

ip route a.b.c.0 255.255.255.0 fa 0/1

Standby Router Configuration

interface fa0/0

ip address 10.10.100.3 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 100 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.n

standby 10 track fa 0/1

!

ip nat inside source static/pool -----redundancy HSRP1

ip classless

ip route a.b.c.0 255.255.255 fa 0/1

ali here in ip nat command you can use the static map or nat pool whatever you are looking for... for command reference this is the link: http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087c4c.html

regards

Devang

devang_etcom Fri, 02/16/2007 - 09:24

ali real ip will come in to the picture when you are going to configure the nat...

like this

ip nat inside source static internalIPaddress globalipaddress redundancyHSRP1

so on both the router you will have different global ip address in the above statement...

regards

Devang

devang_etcom Fri, 02/16/2007 - 09:33

ip route statement here is for your own internal network... 10.10.100.0... you are indicating traffic of your network to outside interface...

ip nat inside source static 10.10.100.n IPaddressofISPA (on active router)

ip nat inside source static 10.10.100.m IpaddressofISPB (on standby router)

regards

Devang

devang_etcom Fri, 02/16/2007 - 09:37

ali,

try the above configuration... its seems to be interesting... i might be gofor the configuration scenario in my office lab in this weekend... let me know it works or not so i can do it in my lab...

its nice to work with you, i learned lots of thing during the providing solution of your scenarios... hay i am sorry if some time i had provide you the out of track solution... i am still learning lots of things i am not that much expert but mostly i am dealing with some basic stuff... after 10 days i am planning to take BGP exam... let see...

thank you very much

regards

Devang

devang_etcom Fri, 02/16/2007 - 09:48

ali this is the ip address of the source which you want to NAT to the Public ip address...

might be any PC server or what ever... i am trying to find out the multiple inside IP buinding to the out side global ip address...

regards

Devang

devang_etcom Fri, 02/16/2007 - 10:00

ali use this for nat...

on Active router

ip nat inside source list 1 interface fa0/1 (activerouterinterface connected to the ISPA) overload

!

access-list 1 permit 10.10.100.0 0.0.0.255

on standby router

ip nat inside source list 1 interface fa0/1 (activerouterinterface connected to the ISPB) overload

!

access-list 1 permit 10.10.100.0 0.0.0.255

devang_etcom Fri, 02/16/2007 - 10:17

yup...

i tried to give you the solution let see... i will check it out in my lab...i think i had created some complexity in confugration as well as in explanation also...

sorry for wasting your time...

thanks and regards

Devang

Actions

This Discussion