Disabling RIP on 6509

Unanswered Question
Feb 15th, 2007

I'm having a problem with our 6509 switch. We have had RIP enabled for a while and we'd like to disable it on this switch because we felt that it was not being used. However when RIP is disabled, after a short period of time, it appears that the 6509 loses its routes. A 'sh ip route' command shows that the route for the subnetwork I'm trying to reach is entered in, in fact it's a local interface in the 6509 so it doesn't even need a static route, it shows connected. However clients on that subnetwork can receive data, but they cannot send any data.

I have noticed that re-enabling RIP fixes this problem almost immediately. Additionally, if I leave RIP disabled, and go to a client machine, and do a 'tracert' into a PC on the network that the switch is on, communications will resume working properly.

I've had a Cisco Engineer look at the config on the switch and he says that it looks to be correct. Does anyone have any ideas what might be causing this scenario? Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Thu, 02/15/2007 - 09:18

Dave

The symptoms that you describe sound like the PCs may be configured to do IP routing and are dependent on RIP sending them a default route. Can you confirm details of how the PCs are configured?

HTH

Rick

Dave Agro Thu, 02/15/2007 - 09:27

Here is a copy of the config. It looks a lot more confusing than it really is. Basically we're having problems with remote users which are on VLan2, or 10.1.2.x adresses.

...

version 12.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime

no service password-encryption

!

hostname msm15

!

boot system flash bootflash:c6msfc-ds-mz.120-7.XE1

enable secret 5

clock timezone CST -6

clock summer-time CDT recurring

clock calendar-valid

ip subnet-zero

ip cef

ip name-server 10.1.1.6

ip name-server 10.1.1.9

!

!

!

!

interface Vlan1

no ip address

no ip directed-broadcast

ip policy route-map RM_VLAN1

shutdown

!

interface Vlan2

ip address 10.1.2.5 255.255.255.0

no ip directed-broadcast

!

interface Vlan11

ip address 10.1.1.5 255.255.255.0

no ip directed-broadcast

ip policy route-map RM_VLAN11

!

interface Vlan19

ip address 10.1.19.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

ip policy route-map RM_VLAN19

!

interface Vlan21

ip address 10.1.21.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan22

ip address 10.1.22.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan23

ip address 10.1.23.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan24

ip address 10.1.24.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan25

ip address 10.1.25.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan26

ip address 10.1.26.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan27

ip address 10.1.27.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan40

ip address 10.1.40.5 255.255.255.0

no ip directed-broadcast

ip policy route-map RM_VLAN40

!

interface Vlan41

ip address 10.1.41.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan42

ip address 10.1.42.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan43

ip address 10.1.43.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan44

ip address 10.1.44.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan45

ip address 10.1.45.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan46

ip address 10.1.46.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

interface Vlan47

ip address 10.1.47.5 255.255.255.0

ip helper-address 10.1.1.9

no ip directed-broadcast

!

router rip

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.250

ip route 10.4.1.0 255.255.255.0 10.1.1.31

ip route 10.9.0.0 255.255.0.0 10.1.1.31

ip route 10.10.1.0 255.255.255.0 10.1.1.1

ip route 10.11.0.0 255.255.0.0 10.1.1.31

ip route 10.12.1.0 255.255.255.0 10.1.1.31

ip route 10.16.1.0 255.255.255.0 10.1.1.31

ip route 10.17.0.0 255.255.0.0 10.1.1.31

ip route 10.99.1.0 255.255.255.0 10.1.1.100

ip route 10.99.2.0 255.255.255.0 10.1.40.90

ip route 10.99.3.0 255.255.255.0 10.1.1.31

ip route 10.99.4.0 255.255.255.0 10.1.40.90

ip route 10.100.0.0 255.255.0.0 10.1.1.31

no ip http server

!

logging trap debugging

logging 10.1.19.114

access-list 111 permit ip 10.1.1.0 0.0.0.255 any

access-list 119 permit ip 10.1.19.0 0.0.0.255 any

access-list 140 permit ip 10.1.40.0 0.0.0.255 any

route-map RM_VLAN40 permit 10

match ip address 140

set ip default next-hop 10.1.1.1

!

route-map RM_VLAN11 permit 10

match ip address 111

set ip default next-hop 10.1.1.1

!

route-map RM_VLAN19 permit 10

match ip address 119

set ip default next-hop 10.1.1.1

!

...

Dave Agro Thu, 02/15/2007 - 09:29

Rick,

I guess I could see that, however we aren't on any special configuration. Normal Windows domain, using this switch/router as the default gateway.

-Dave

Richard Burts Thu, 02/15/2007 - 09:51

Dave

I have looked through the config that you posted and nothing stands out as a potential issue. I continue to feel that this is more likely an issue with something on the PC than it is an issue on the 6509.

I went back and read again your original post. Do I understand correctly that if you turn off RIP, and then from a PC do a tracert to another PC that things start to work again? Are the address of the PC that you tracert to in any particular subnet?

HTH

Rick

Actions

This Discussion