CUE Message Addressing

Unanswered Question
Feb 16th, 2007

I have a CME/CUE installation up and running without issues. I am however getting some customer feedback on how CUE addresses forwarded voice messages by default.

When logged into voicemail and you forward a message, by default CUE asks you to spell the persons name. If you'd rather enter the extension- press ##. The customer in question would rather have extension be the default and ## would allow you to dial by name.

Is there any way to change the default behavior for that? I've checked the GUI Admin, the CLI Admin, the User Guide, and the Quick Start Guide, but I didn't see any mention of changing the default to addressing by extension.

Thanks for any help.

Justin

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
carenas123 Thu, 02/22/2007 - 07:34

The Cisco IOS dialplan-pattern command is intended to make all Voice over IP (VoIP) calls use E.164 numbers.

When a CME is configured with a dialplan-pattern command that encompasses the CUE pilot access number, the CUE must therefore be configured to accept incoming calls that use an E.164 number. This is a similar situation to a direct dial into CUE (for example to retrieve voice messages) using an external phone. For example, voice mail 9017 becomes 01159829017. Adjustments need to be made on the CUE accordingly.

This is a workaround for this problem:

Downgrade to Cisco IOS Software release 12.3(7)T1. This interoperability problem has been reported in 12.3(8)T images only.

Do not use the dialplan-pattern telephony-service command.

Create a translation-rule on the CME for the dial-peer pointing to the CUE. This translation rule is used to convert the E.164 number back to extension number format so it is acceptable to CUE.

This is a configuration example:

voice translation-rule 1

rule 1 /0115982\(....\)/ /\1/

!

!

voice translation-profile cue

translate called 1

dial-peer voice 100 voip

description Voicemail number

translation-profile outgoing cue

destination-pattern 01159829017

session protocol sipv2

session target ipv4:172.16.32.61

codec g711ulaw

no vad

!

In this way, any number sent to the voice mail is sent as a 4-digit number, and you do not need to modify anything on the CUE.

Multiple triggers may be configured on CUE through the Command Line Interface (CLI).

This is an example of two triggers for voicemail applications, one with trigger 3380 and the other with trigger 4085553380. Repeat this for all the applications (VM, AA, GMS) for which you need E.164 support:

ccn trigger sip phonenumber 3370

application "autoattendant"

enabled

locale "en_US"

maxsessions 4

end trigger

ccn trigger sip phonenumber 3380

application "voicemail"

enabled

locale "en_US"

maxsessions 4

end trigger

ccn trigger sip phonenumber 3390

application "promptmgmt"

enabled

locale "en_US"

maxsessions 1

end trigger

ccn trigger sip phonenumber 4085553380

application "voicemail"

enabled

locale "en_US"

maxsessions 4

end trigger

justinbois Thu, 02/22/2007 - 10:19

Thank you very much for your response, the effort is much appreciated. Unfortunately, the issue isn't in getting phones to ring into voicemail. Rather, it is when a user logs into voicemail, finds a message they need to forward to another user on the same system and they go through the TUI to specify whom to forward the message to. By default, CUE wants you to type in the other user's name. If you'd rather type in their extension, press ##. The customer I'm working with wants the default addressing of forwarded voicemails to be via extension, not the dial-by-name option.

Hopefully I made it more clear that time. Thank you again for your help thus far.

adrianotte Thu, 05/29/2008 - 14:22

I have the same issue. Does anyone know a fix for this. When trying to forward a voicemail from CUE to another user on CUE, it defaults to dial by name.

Is there any way to change it to ask for the extension first?

Thanks.

rob.huffman Thu, 05/29/2008 - 14:50

Hi Adrian,

This change is possible in CUE Versions 3.0 and later :)

Configuring Default Addressing for Sending a Voice Message

Prior to 3.0, you could not specify whether voice messages were addressed by name or extension at the system level for all the features. With 3.0, the default setting is the same as the previous version, which is to address the message by name.

SUMMARY STEPS

1. config t

2. voicemail conversation address-by {extension | name}

3. end

4. (Optional) show voicemail conversation {caller | subscriber}

From this good doc;

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel3_0/administration/guide/voicemail/3VMpara.html

Hope this helps!

Rob

adrianotte Fri, 05/30/2008 - 05:57

This is better than tech support :)

Rob,

Worked liked a champ. Thanks.

rob.huffman Sat, 05/31/2008 - 06:44

Hi Adrian,

You are most welcome my friend :) Glad to be of some small help here.

Thanks again,

Rob

Actions

This Discussion