2 Wirless Link From 2 ISPs

Unanswered Question

Kindly,have a look to the attached diagram;as well as to the Config provided from Devang!

i have 2 wireless connection from 2 different ISPs(ISPA;ISPB)ISP A Terminate link at R1;ISPB Treminate link at R2;i want to achieve the following setup:if the first Link(ISPA)fail the second link (ISPB) TAKE OVER.R1 ITS PRIMARY;R2 ITS SECONDERY.e.g continuous internet access in case on of link goes down

How can i CONFIGURE like this setup?can i do load Balence?

Config like this:

*****************

active router(R1)

*****************

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 105 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.1

standby 10 track Fa 0/1

!

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit 10.10.100.0 0.0.0.255

!

int f0/1

ip address 202.10.10.1 255.255.255.252

ip nat outside

Standby Router(R2)

******************

interface fa0/0

ip address 10.10.100.3 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 100 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.1

standby 10 track Fa 0/1

!

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit 10.10.100.0 0.0.0.255

!

int f0/1

ip address 194.126.10.1 255.255.255.252

ip nat outside

10xs for ur reply & for ur examination!

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ahmednaas Sun, 02/18/2007 - 15:16

This config looks OK. Did you test it on your network?

In this next scenario you route some of your VLANs to R1 with R2 as backup and some VLANs to R2 with R1 as backup. Notice you now have 2 virtual interfaces:

*****************

router(R1)

*****************

interface fa0/0

ip address 10.10.100.1 255.255.255.255.0

stabdby 10 preempt

standby 10 priority 120

standby 10 ip 10.10.100.3

standby 20 ip 10.10.100.4

Router(R2)

******************

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

standby 20 preempt

standby 20 priority 120

standby 20 ip 10.10.100.4

standby 10 ip 10.10.100.3

ahmednaas Mon, 02/19/2007 - 02:19

What does your switch configuration look like?

Do you have the routers in a separate VLAN?

ahmednaas Mon, 02/19/2007 - 03:50

Yes, what you describe is right.

The two routers also need to communicate with each other so they can exchange HSRP protocol messages.

ahmednaas Mon, 02/19/2007 - 05:06

There is no substitute for testing.

Configure your routers and test. If you have problems, use troubleshooting commands (mainly show ..., Or debug) and post the output on this forum.

Actions

This Discussion