Simple routing question

Unanswered Question
Feb 18th, 2007

Hello

i ahve 2 routers, ROUTER A is connected to the internet through DSL interface, and is connected to a switch through FE0/0 which has the ip address 10.10.10.1 and network: 10.10.10.0/24

ROUTER B , its FE0/0 has the same network 10.10.10.0/24 and ip address 10.10.10.2 and its connected to the switch, and FE0/1 has a diffrent network 192.168.0.0 255.255.0.0 and ip address 192.168.100.1, now i am connecting my computer DIRECTLY to FE0/1 on ROUTER B, i am able to get DHCP IP Address, but not able to ping ROUTER A from my computer nor see the internet.

ROUTER B can ping ROUTER A and see the internet.

i am attaching the config on ROUTER B, if someone can help:

RouterB#sh run

Building configuration...

Current configuration : 1015 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable password mans321

!

no aaa new-model

!

!

ip cef

ip name-server 10.10.10.1

no ip dhcp use vrf connected

!

ip dhcp pool ADSL

network 192.168.0.0 255.255.0.0

dns-server 10.10.10.1

default-router 10.10.10.1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.100.1 255.255.0.0

duplex auto

speed auto

!

no ip http server

!

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

!

access-list 13 permit 192.168.0.0 0.0.255.255

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

line con 0

line 33 48

line 65 80

line 97 112

line 129 144

line aux 0

line vty 0 4

password XXXX

login

!

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mrmozaffari Sun, 02/18/2007 - 02:48

Hi

Is there any route in router A to point to 192.168.0.0/16 ?

It seems that there is no route to this network in router A like this :

ip route 192.168.0.0 255.255.0.0 10.10.10.2

also after you put this route in router A maybe you need to Nat the addresses since you use 192.168.0.0 network , B router sees the internet because it uses its Fe0/0 ip address.

Best Regards Bahman Mozaffari.

Please Rate if it helpful.

xbaha12345 Sun, 02/18/2007 - 09:56

no i didnt specify any route in router A, do i have to do that? isnt there a way do do that from router B?

i will try this and will let you know.

thanks.

Jon Marshall Sun, 02/18/2007 - 03:27

Hi

I think you should change the default-router from 10.10.10.1 to 192.168.100.1 under your DHCP configuration on RouterB. Your PC will have a default gateway of 10.10.10.1 at the moment but it is on the 192.168.0.0/16 network so it won't know how to get to 10.10.10.1.

HTH

Jon

xbaha12345 Sun, 02/18/2007 - 22:00

hello

i did change the default-route to 192.168.100.1, but nothing changed, i still cant ping the gateway nor get to the internet.

any other suggestions?

thanks

Danilo Dy Sun, 02/18/2007 - 22:09

Hi,

The "show run" above is from your router B, therefore the default gateway is correct "ip route 0.0.0.0 0.0.0.0 10.10.10.1".

Questions is;

- Does Router A has a route to 192.168.0.0/16 which is "ip route 192.168.0.0 255.255.0.0 10.10.10.2?

- Does Router A has NAT Pool that includes 192.168.0.0/16?

BTW, does your routers has a statement "ip classless" ?

Can you post the Router A config?

The reason Router B can ping Router A and internet is because it has an interface in the network 10.10.10.0/24 and using it to ping Router A and internet

xbaha12345 Sun, 02/18/2007 - 22:31

no i didnt have any of these,

here however the conf on ROUTER A:

note gig0/0 is connected to the switch

gig0/1 is not connected to the switch.

Current configuration : 25200 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ROUTERA

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

no logging console

enable secret 5 $1$b6YW$40H5XRga4vamKku23nRSu1

!

aaa new-model

!

!

aaa authentication login default local group radius

aaa authentication enable default enable

aaa authentication ppp default local group radius

aaa authorization exec default local group radius

aaa authorization network default local group radius

!

aaa session-id common

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

ip domain name xx.xx.xx.xx

ip name-server xx.xx.xx.xx

vpdn enable

!

!

username xxxxxx password 0 xxxxx

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.10.10.1 255.255.255.0 secondary

ip address xxx.xxx.111.177 255.255.255.248

ip nat inside

ip tcp adjust-mss 1452

load-interval 30

duplex auto

speed auto

media-type rj45

negotiation auto

!

interface GigabitEthernet0/1

ip address 192.168.0.1 255.255.0.0

ip nat inside

ip tcp adjust-mss 1452

duplex auto

speed auto

media-type rj45

negotiation auto

!

!

interface ATM0/1/0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 0/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

!

interface Dialer1

mtu 1482

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username xxxxxxxxx password 0 xxxxxxxx

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http access-class 23

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat pool Internet xxx.84.111.181 xxx.84.111.182 netmask 255.255.255.248

ip nat pool DSL xxx.xxx.111.173 xxx.xxx.111.174 netmask 255.255.255.252

!

no logging trap

access-list 10 permit 10.10.10.9

access-list 11 permit 10.10.10.0 0.0.0.255

access-list 12 permit 192.168.0.0 0.0.255.255

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 101 permit ip 10.10.10.0 0.0.0.255 any

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

access-list 149 permit ip any any log

snmp-server community commaccess RO 10

snmp-server community CUS123 RO

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

privilege level 15

transport input telnet

line vty 5 15

privilege level 15

transport input telnet

!

no scheduler allocate

!

end

Danilo Dy Sun, 02/18/2007 - 23:12

Your RotuerB should have the following;

!

ip subnet-zero

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

Your RouterA should have the following;

!

ip subnet-zero

!

ip classless

ip route 192.168.0.0 255.255.0.0 10.10.10.2

!

Danilo Dy Sun, 02/18/2007 - 23:25

May I ask you a question? What is this?

ip nat pool Internet xxx.84.111.181 xxx.84.111.182 netmask 255.255.255.248

ip nat pool DSL xxx.xxx.111.173 xxx.xxx.111.174 netmask 255.255.255.252

MY NATing seems to be rusty, as I can't figure out the use of this from your configuration. Does your internet provider give you Public IP Address subnet to NAT to your Private IP Addresses?

xbaha12345 Sun, 02/18/2007 - 23:35

hi

ip nat pool Internet xxx.84.111.181 xxx.84.111.182 netmask 255.255.255.248 is for natting my local IPs to the internet.

the second one: ip nat pool DSL xxx.xxx.111.173 xxx.xxx.111.174 netmask 255.255.255.252 is not yet finished, but i am working with my ISP to setup EIGRP because i will have multiple DSL lines connected.

as i said, the ip route worked, but the internet is slow, and some other applications other than HTTP is not working, like outlook, messenger.

any idea what happened?

Danilo Dy Sun, 02/18/2007 - 23:52

Ok, to make sure you got everything, here are the configuration suggestions (don't miss any of the lines);

1. Routing

Your RouterB should have the following;

!

ip subnet-zero

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

Your RouterA should have the following;

!

ip subnet-zero

!

ip classless

ip route 192.168.0.0 255.255.0.0 10.10.10.2

!

2. NATing

Your RouterA should have the following;

!

interface Dialer1

mtu 1492 << 1492 not 1482

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username xxxxxxxxx password 0 xxxxxxxx

ppp multilink

!

ip nat pool Internet xxx.84.111.181 xxx.84.111.182 netmask 255.255.255.248

ip nat inside source list 11 pool Internet

!

access-list 11 permit 10.10.10.0 0.0.0.255

access-list 11 permit 192.168.0.0 0.0.255.255

!

dialer-list 1 protocol ip permit

xbaha12345 Sun, 02/18/2007 - 22:54

ok, i did add ip route 192.168.0.0 255.255.0.0 10.10.10.2 and i was able to ping Router A, i am able to get to the internet but it seems much slower than if i am directly connected, how can i do the natting and on which router?

thanks.

Actions

This Discussion