Trying to archive configs of Cisco 4948 switches

Unanswered Question
Feb 18th, 2007

We have started deploying a few Cisco 4948 devices and we seem to be having problems getting the configs off them.

In the Configuration Archival Summary report, Partially Successful we get the the following message when trying to get the Startup config:

TFTP: Failed to fetch config using TFTP. Failed to get the start tag-! in the configuration.Check if the startup-config file is present on the device.

We get the Running Config and the VLAN database.

At first I thought it was because I hadnt loaded the latest device updates, but I have finished doing that, and we still get the same error.

Any ideas as to what else needs to be done?

Regards

jeff

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Mon, 02/19/2007 - 06:51

What version of RME are you running? What version of IOS on the 4948?

If you run show start on the switch do you get any output?

It looks like you might be hitting bug CSCsa94931 for the 4948's

Jeff Law Mon, 02/19/2007 - 13:26

I am running version 4.0.5 of RME.

Version of IOS is:

Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500-IPBASE-M), Version 12.2(31)SG, RELEASE SOFTWARE (fc2) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2006 by Cisco Systems, Inc. Compiled Tue 14-Mar-06 17:05 by ssear

Output from the show start command:

Switch1#sh start

Using 3890 out of 524280 bytes, uncompressed size = 10212 bytes

Uncompressed configuration from 3890 bytes to 10212 bytes

!

version 12.2

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

service compress-config

....

Reading about that bug does seem very similar except it was supposed to be fixed prioir to the version of RME that we are running. I will keep looking to see if I can find any common factors, but if there are any ideas I would be interested in them.

Thanks

Jeff

Joe Clarke Mon, 02/19/2007 - 14:07

You might try manually copy the startup config to your RME TFTP server, and see what its first line is. Also, enabling ArchiveMgmt Service debugging under RME > Admin > System Preferences > Loglevel Settings, then re-running your failing job should reveal more information in the dcmaservice.log.

Jeff Law Mon, 02/19/2007 - 17:50

Well, that was interesting. Looks like TFTP is failing and so RME is using telnet to attempt to do its copying.

The telnet responds correctly when it has issued the show running-config brief command, but apparently it doesnt when it does the show startup command.

I can attach the debug file if it is of any use, or a portion of it.

I am investigating why tftp is failing - could well be a firewall rule as these devices are in a different partition that is just being set up.

Joe Clarke Mon, 02/19/2007 - 18:57

For this problem, a sniffer trace in addition to the debug log are the best sources of information.

Actions

This Discussion