cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
358
Views
0
Helpful
2
Replies

2 adsl dialers on the same router

blacktulip
Level 1
Level 1

hey,

i have 2 adsl lines i need to connect to 1 router. i can't change the pvc number or take 1 big line. i also need to have load sharing between the lines.

so far i did so by 2 vrfs - only way the lines work together, because of the same pvc as far as i know. i ran bgp and then i could route between the vrfs, but i can't ping to the dialer if it's in different vrf.

can someone help? thanks.

2 Replies 2

purohit_810
Level 5
Level 5

Hi,

Can you give me some configuration and digram what you have did??

Regards,

Dharmesh Purohit

the configuration is followed, the diagram is attached.

the weird thing is i can route between different vrfs except for the dialer, which can be reached only from the same vrf.

configuration:

*****************

no ip domain lookup

ip domain name *****

ip name-server ***.***.***.***

ip name-server ***.***.***.***

!

ip dhcp pool 1

********

!

ip vrf LAN

rd 300:1

route-target export 300:1

route-target import 300:1

route-target import 100:1

route-target import 200:1

!

ip vrf vrf1

rd 100:1

route-target export 100:1

route-target import 100:1

route-target import 200:1

route-target import 300:1

!

ip vrf vrf2

rd 200:1

route-target export 200:1

route-target import 200:1

route-target import 100:1

route-target import 300:1

!

ip audit po max-events 100

!

interface Loopback0

ip vrf forwarding vrf1

ip address *****

!

interface Loopback1

ip vrf forwarding vrf2

ip address *****

!

interface Loopback2

ip vrf forwarding LAN

ip address *****

!

interface ATM0/0

ip vrf forwarding vrf1

ip address ******

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0/0

** TO LAN ***

ip vrf forwarding LAN

ip address *****

ip nat inside

speed 100

full-duplex

!

interface ATM0/1

ip vrf forwarding vrf2

ip address ****

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 2

!

!

interface Dialer1

ip vrf forwarding vrf1

ip address negotiated

ip mtu 1492

ip nat outside

ip cef accounting non-recursive external

ip nbar protocol-discovery

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username *******************

!

interface Dialer2

ip vrf forwarding vrf2

ip address negotiated

ip mtu 1492

ip nat outside

ip cef accounting non-recursive external

ip nbar protocol-discovery

encapsulation ppp

dialer pool 2

dialer-group 2

no cdp enable

ppp authentication pap callin

ppp pap sent-username *****************

!

router bgp 1

no synchronization

bgp log-neighbor-changes

no auto-summary

!

address-family ipv4 vrf vrf2

redistribute connected

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 vrf vrf1

redistribute connected

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 vrf LAN

redistribute connected

no auto-summary

no synchronization

exit-address-family

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 2 interface Dialer2 overload

ip nat inside source route-map adsl1 interface Dialer1 vrf vrf1 overload

ip http server

no ip http secure-server

ip classless

ip route vrf LAN 0.0.0.0 0.0.0.0 Dialer1

ip route vrf vrf1 0.0.0.0 0.0.0.0 Dialer1

!

!

access-list 1 permit any

access-list 2 permit any

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

route-map adsl2 permit 10

match interface Dialer2

!

route-map adsl1 permit 10

match interface Dialer1

end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card