E1 trunk only takes one channel

Unanswered Question
Feb 20th, 2007

Hi I have an E1 trunk to Avaya s8400

The thing is that the first call can be completed and is working fine, once that other phone makes a second phone call we see that the second channel was taken but there is no audio.

The main configuration is:

controller E1 2/0

framing NO-CRC4

pri-group timeslots 1-31

!

isdn switch-type primary-net5

!

interface Serial2/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn overlap-receiving

isdn incoming-voice voice

isdn send-alerting

isdn bchan-number-order ascending

isdn sending-complete

isdn outgoing display-ie

!

dial-peer voice 10 pots

incoming called-number ....

destination-pattern 1...

no digit-strip

direct-inward-dial

port 2/0:15

forward-digits all

!

dial-peer voice 60 voip

destination-pattern 6...

session target ipv4:1.96.1.1

codec g729br8

ip qos dscp cs5 media

!

dial-peer voice 30 voip

destination-pattern 3...

session target ipv4:1.48.1.1

codec g729br8

ip qos dscp cs5 media

!

Any idea what is going on?

I'm attaching a debug that shows that first call reaches 3700, and second call(with no audio) to 6700.

Thanks in advance!

Orlando

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lpezj Tue, 02/20/2007 - 07:00

Orlando,

try to change the 'isdn bchan-number-order ascending' for 'isdn bchan-number-order descending'.

Sometimes this has worked for me.

Hope this helps,

Juan Luis

omendieta77 Tue, 02/20/2007 - 07:10

I tried and it didn't work.

I've even just enabled the second channel, and I get no audio.

Here is a debug of it.

BNB-LPZ-A#

Feb 20 15:05:07.345: ISDN Se2/0:15 Q931: RX <- SETUP pd = 8 callref = 0x5901

Sending Complete

Bearer Capability i = 0x9090A3

Standard = CCITT

Transer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18382

Preferred, Channel 2

Progress Ind i = 0x8183 - Origination address is non-ISDN

Called Party Number i = 0x80, '6700'

Plan:Unknown, Type:Unknown

Locking Shift to Codeset 6

Codeset 6 IE 0x28 i = 'Prueba'

Feb 20 15:05:07.353: ISDN Se2/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0xD90

1

Channel ID i = 0xA98382

Exclusive, Channel 2

Feb 20 15:05:08.641: ISDN Se2/0:15 Q931: TX -> PROGRESS pd = 8 callref = 0xD901

Progress Ind i = 0x8188 - In-band info or appropriate now available

Feb 20 15:05:48.457: ISDN Se2/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x59

01

Cause i = 0x8190 - Normal call clearing

Feb 20 15:05:48.461: ISDN Se2/0:15 Q931: TX -> RELEASE pd = 8 callref = 0xD901

Feb 20 15:05:48.477: ISDN Se2/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x

5901

Feb 20 15:07:10.011: %SYS-5-CONFIG_I: Configured from console by vty2 (1.16.2.23

6)

Feb 20 15:07:15.207: ISDN Se2/0:15 Q931: RX <- SETUP pd = 8 callref = 0x5982

Sending Complete

Bearer Capability i = 0x9090A3

Standard = CCITT

Transer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18382

Preferred, Channel 2

Progress Ind i = 0x8183 - Origination address is non-ISDN

Called Party Number i = 0x80, '6700'

Plan:Unknown, Type:Unknown

Locking Shift to Codeset 6

Codeset 6 IE 0x28 i = 'Prueba'

Feb 20 15:07:15.215: ISDN Se2/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0xD98

2

Channel ID i = 0xA98382

Exclusive, Channel 2

Feb 20 15:07:16.503: ISDN Se2/0:15 Q931: TX -> PROGRESS pd = 8 callref = 0xD982

Progress Ind i = 0x8188 - In-band info or appropriate now available

Feb 20 15:07:40.778: ISDN Se2/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x59

82

Cause i = 0x8190 - Normal call clearing

Feb 20 15:07:40.782: ISDN Se2/0:15 Q931: TX -> RELEASE pd = 8 callref = 0xD982

Feb 20 15:07:40.798: ISDN Se2/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x

5982

I don't get this event:

Feb 20 13:59:53.130: ISDN Se2/0:15 Q931: RX <- SETUP pd = 8 callref = 0x4680

any more ideas?

Paolo Bevilacqua Tue, 02/20/2007 - 08:50

Do you have compand-type a-law under voice-port ?

What platform is this ? Can you send debug

omendieta77 Tue, 02/20/2007 - 09:08

Now I've configured a-law, but the problem persists.

this router is a 3725.

cisco 3725 (R7000) processor (revision 0.1) with 119808K/11264K bytes of memory.

Processor board ID JMX0642L7XA

R7000 CPU at 240Mhz, Implementation 39, Rev 3.3, 256KB L2 Cache

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

Primary Rate ISDN software, Version 1.1.

2 FastEthernet/IEEE 802.3 interface(s)

4 Serial network interface(s)

4 Serial(sync/async) network interface(s)

8 Low-speed serial(sync/async) network interface(s)

1 Channelized E1/PRI port(s)

DRAM configuration is 64 bits wide with parity disabled.

55K bytes of non-volatile configuration memory.

31296K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x2102

I've attached a debug in a previous message.

thanks,

Orlando

Paolo Bevilacqua Tue, 02/20/2007 - 09:27

I do not see the hw codecs in show version.. nor the IOS version.

perhaps show diag would tell what you have.

Also, when you have two calls, look at "show voice dsp". it is important to understand how codec are allocated.

Actions

This Discussion