CME with SIP

Unanswered Question

Hi,

I am connecting a cisco 2811 ios 12.4(11)XJ with callmanager express to a UK SIP provider voipfone.

The problem I am having is that, I can make calls to any voipfone numbers but calls getting disconnected as soon as I call a landline or mobile....

I have added the relevant config below:

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

codec preference 4 g729br8

!

!

voice translation-rule 1

rule 1 /^05600040277$/ /1001/

rule 2 /.*/ /1002/

!

voice translation-rule 2

rule 1 /^9*/ //

!

voice translation-rule 3

rule 1 /.*/ /08704711587/

!

!

voice translation-profile Incoming-Sip

translate called 1

!

voice translation-profile SIP

translate calling 3

translate called 2

!

dial-peer voice 1000 voip

description Inbound Dialpeer usinng voipphone

translation-profile incoming Incoming-Sip

preference 1

answer-address 05600040382

destination-pattern 1...

voice-class codec 1

session protocol sipv2

session target dns:sip.voipfone.co.uk

incoming called-number 05600040382

!

dial-peer voice 10 voip

description #outgoing peer#

translation-profile outgoing SIP

destination-pattern 9T

voice-class codec 1

session protocol sipv2

session target dns:sip.voipfone.co.uk

dtmf-relay cisco-rtp h245-alphanumeric h245- signal rtp-nte sip-kpml sip-notify

!

----------

I also tried using different codec as below:

dial-peer voice 10 voip

codec g711ulaw, g711alaw etc

and that did not help either.

Please can you let me know if I am doing something wrong?

I am also attaching a output from debug ccsip messages when the lines are getting cut.

Many thanks

Anwar

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Paolo Bevilacqua Tue, 02/20/2007 - 08:45

Hi,

The provider does not specify a reason why the call is cut, I can only suppose it's because lack of proper authentication.

Please configure sip-ua and put the appropriate username/password/realm in there, together with any other needed option.

Then collect debuc ccsip message again.

Hi,

Many thanks for the reply.

I think you are right...If I do a show sip-ua register status, I do not see anything. I was expecting to see the proder sip registration, correct?

Thing that is confusing me is how am I able to make calls to a local number that belongs to the sip provider, voipfone.. I have attached a debug ccsip messages for a voipfone number (not breaking out to PSTN)

Also, I get the following from debug ccsip error when I dial out...

CME01#debug ccsip error

SIP Call error tracing is enabled

CME01#

Feb 21 09:21:01.395: //13/AC76EBF48024/SIP/Error/sipSPIProcessCallInfoHeader: Ca

ll-Info header with for Unsolicited Notify Absent,Disabling Unsolicited Notifies

Paolo Bevilacqua Wed, 02/21/2007 - 01:30

Registration is not needed for placing outgoing calls. It is merely a mechanism to tell the provider, send calls to the number I register, here.

By default, IOS will try to register all the POTS dial-peers and number for ephone-DN.

Perhaps you are able to place some calls because these are free, although I do not see a connect message in the debug you sent.

Thanks.

I finally managed to register CME with another provider sipgate and able to make outbound calls. (Voipfone with the same settings) does not register.

Few modifications I had to make to get it work properly. Thoght I should let you know. The dial peer and the ephone-dn needs a reference to the my sipgate account number as below:

dial-peer voice 10 voip

description #outgoing peer#

translation-profile outgoing SIP

preference 1

destination-pattern 9T

session protocol sipv2

session target dns:sipgate.co.uk

dtmf-relay rtp-nte

codec g711ulaw

clid network-number SIPGATE_ACCOUNT

no vad

---

ephone-dn 57 dual-line

number 1003 secondary SIPGATE_ACCOUNT no-reg primary

name Andy

----

Many thanks for your help.

I am now having problem with DTMF. Any idea how I can troubleshoot this? I am using rtp-nte in the dial-peer as you can see.

Paolo Bevilacqua Sat, 03/03/2007 - 12:51

Hi,

good to know basic calls are working now. Have you tried "dtmf-relay sip-notify" ? Perhaps is what the ITSP wants. To debug, enable "debug ccsip messages".

Paolo Bevilacqua Tue, 03/06/2007 - 09:07

Hi,

I was looking at your traces, expecting to see the SIP NOTIFY messages, but I don't,

Let me dig deeper into this, verify few things, and I will be back to you.

Paolo Bevilacqua Thu, 03/08/2007 - 10:51

Hello,

I found that with "dtmf-relay rtp-nte", I can send DTMF from a SCCP phone to SIP phone.

Instead, "dtmf-relay sip-notify" does not work and no SIP messages are generated in debug.

I think the issue can be the same with a SIP provider instead of SIP softphone.

I suggest that you open a case with the TAC to better understand what is happening.

Actions

This Discussion