ANI Server with busy flag set

Unanswered Question
Feb 20th, 2007

Hello

I have pb with ANI SERVER Process witch is displyed with busy flag set!!

I stop and restart the process many...but the status is always busy. I also reinstall Campus Manager but same result

I have Ciscoworks version 2.5.1

Any idea for resolving pb??

I will appreciat your Help

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (5 ratings)
Loading.
David Stanford Tue, 02/20/2007 - 10:10

The proper status for ANIServer is running with busy flag set. There is no problem and it is expected to be in this state.

microtel Tue, 02/20/2007 - 10:15

Thanks for fast reply..

Sorry, but i do not mention that i can not access to the toplogy services and path analisys!!

So it's a pb!!

David Stanford Tue, 02/20/2007 - 10:24

The process status still isn't the problem. What errors are you getting when you try to access Topology services? What is your browser version and OS?

microtel Tue, 02/20/2007 - 10:30

The message is:

Cannot connect to ANIServer 5.0.3

verify thet ANIServer5.0.3 is running and restart Campus Manager

IE 6.0 with SP2 on XP

Joe Clarke Tue, 02/20/2007 - 10:57

The most common problems with connecting to ANIServer involve proxy or firewalls. You should disable all proxying in your Java Plug-in control panel, and make sure that TCP ports 1683, 1684, and 8088 are open between the client and the server.

You should also make sure you're using the correct version of the Java Plug-in. Currently this is 1.4.2_10 without the recent Daylight Savings Time patch, and 1.4.2_12 with the patch.

Finally, check the output in the Java Plug-in console, as it can be very telling as to why the client cannot connect to ANIServer.

microtel Wed, 02/21/2007 - 02:45

Thank u clarke!!

Undeed, the TCP ports 1683 and 1684 were blocked by an ACL!!

frankzehrer Tue, 02/20/2007 - 22:55

Hi Malek,

maybe the ANIServer.properties in the path

Windows: Installdir\CSCOpx\campus\etc\cwsi

Solaris: opt\CSCOpx\campus\etc\cwsi

is corrupted. Rename it to e.g. ANIServer.properties.old and copy the ANIServer.properties.orig to ANIServer.properties.

This will reset the Campus Manager settings to the factory default.

If this does not help try the reset of the ANI-DB.

Open a DOS shell and issue the command:

net stop crmdmgtd

Unix: \etc\init.d\dmgtd stop

Windows Only: Once you get the prompt back, open up the task manager and go to processes.

If any of these processes are listed, kill them manually:

sm_server

sm_authority

brstart

Now, go to CSCOpx\campus\bin and issue the command:

perl reinitdb.pl ?restore

To re-start the CiscoWorks application:

net start crmdmgtd

Unix: \etc\init.d\dmgtd start

Wait 5-10 minutes and login to CiscoWorks

Note: This will erase the ANI-DB!!

This should help in most cases of the ANI-DB connection problem.

Good Luck,

Frank

Actions

This Discussion